sailfin
  1. sailfin
  2. SAILFIN-1986

~1500 "ConvergedHttpSession unexpectedly null" messages in the cluster (server logs)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: milestone 1
    • Component/s: session_replication
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      Parent Issue: 1983
      Build: 31b 15th nightly

      All instances except the failed/restarted instance instance105 have these
      messages. The messages indicates session loss. The message is printed from the
      Http Servlet of the app. The http request is expected to find a previously
      created CHS but finds it to be null.

      Here's a sample:

      [#|2009-09-15T22:40:09.359+0530|SEVERE|sun-glassfish-comms-server2.0|javax.enterprise.system.container.web|_ThreadID=84;_ThreadName=httpSSLWorkerThread-28080-1;_RequestID=b45f8410-be36-4adf-bb8d-208c0280bf5c;|StandardWrapperValve[ConferenceHttpServlet]:
      PWC1406: Servlet.service() for servlet ConferenceHttpServlet threw
      exceptionjava.rmi.ServerException: processSecondPage: ConvergedHttpSession
      unexpectedly null
      at
      com.sun.asqe.systemtest.conference.http.ConferenceHTTPServlet.processRequest(ConferenceHTTPServlet.java:51)
      at
      com.sun.asqe.systemtest.conference.http.ConferenceHTTPServlet.doPost(ConferenceHTTPServlet.java:262)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:427)
      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:315)
      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:287)
      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:218)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
      at
      com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:98)
      at
      com.sun.enterprise.ee.web.sessmgmt.SessionLockingStandardPipeline.invoke(SessionLockingStandardPipeline.java:120)
      at
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:222)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1093)
      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:166)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1093)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:291)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:666)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:597)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:872)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:341)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:263)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:214)
      at
      org.jvnet.glassfish.comms.clb.proxy.portunif.ClbProxyPipeline$PUTask.doTask(ClbProxyPipeline.java:532)
      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:264)
      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)

      #]

        Issue Links

          Activity

          varunrupela added a comment -

          updated keyword and dependencies

          Mahesh Kannan added a comment -

          The root cause is same as 1992

          Mahesh Kannan added a comment -

          Fixed. See 1992

          varunrupela added a comment -

          Verified with build 31c.
          3 such messages seen in the logs.


            People

            • Assignee:
              Mahesh Kannan
              Reporter:
              varunrupela
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: