sailfin
  1. sailfin
  2. SAILFIN-1987

~75 "SipApplicationSession unexpectedly null" messages in the failed/restarted instance after restart.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: milestone 1
    • Component/s: session_replication
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      Parent Issue: 1983
      Build: 31b 15th nightly

      Only the failed/restarted instance instance105 has ~75 of these messages after
      it was restarted. The last such message appears around the time when the
      load-factor on other instances reaches the value 1. The message is printed from
      the Http Servlet of the app. The http request is expected to find a previously
      created CHS and the SAS it was linked with. The request seems to find the CHS
      but finds the SAS to be null.

      Here's a sample:

      [#|2009-09-15T23:12:27.935+0530|SEVERE|sun-glassfish-comms-server2.0|Conference|_ThreadID=41;_ThreadName=httpSSLWorkerThread-28080-3;_RequestID=f38b8bd3-01db-4d70-a5e3-9279844c3cab;|ERROR:
      Exception processing the following request, page = final , sasKey =
      conf5070_162760, sessionID = ecb6e5a9f0bbf0da743766be2202
      java.io.IOException: processSecondPage: SipApplicationSession unexpectedly null

      • conf5070_162760
        at
        com.sun.asqe.systemtest.conference.http.ConferenceHTTPServlet.validateCHSAndSAS(ConferenceHTTPServlet.java:121)
        at
        com.sun.asqe.systemtest.conference.http.ConferenceHTTPServlet.processFinalPage(ConferenceHTTPServlet.java:209)
        at
        com.sun.asqe.systemtest.conference.http.ConferenceHTTPServlet.processRequest(ConferenceHTTPServlet.java:44)
        at
        com.sun.asqe.systemtest.conference.http.ConferenceHTTPServlet.doPost(ConferenceHTTPServlet.java:262)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
        at
        org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:427)
        at
        org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:315)
        at
        org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:287)
        at
        org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:218)
        at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
        at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
        at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:94)
        at
        com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:98)
        at
        com.sun.enterprise.ee.web.sessmgmt.SessionLockingStandardPipeline.invoke(SessionLockingStandardPipeline.java:120)
        at
        org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:222)
        at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
        at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
        at
        org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1093)
        at
        org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:166)
        at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
        at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
        at
        org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1093)
        at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:291)
        at
        com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:666)
        at
        com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:597)
        at
        com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:872)
        at
        com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:341)
        at
        com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:263)
        at
        com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:214)
        at
        org.jvnet.glassfish.comms.clb.proxy.portunif.ClbProxyPipeline$PUTask.doTask(ClbProxyPipeline.java:532)
        at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:264)
        at
        com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)
        #]

        Issue Links

          Activity

          varunrupela added a comment -

          updated keyword and dependencies

          Mahesh Kannan added a comment -

          The root cause is same as 1992

          Mahesh Kannan added a comment -

          In Steve's run with the deadlock patch we saw only 12 of them.


            People

            • Assignee:
              Mahesh Kannan
              Reporter:
              varunrupela
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: