Issue Details (XML | Word | Printable)

Key: SAILFIN-383
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: elnyvbo
Reporter: easarina
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
sailfin

the removing of a header from one request should not affect other requests

Created: 14/Jan/08 01:59 PM   Updated: 27/Oct/08 07:05 PM   Resolved: 27/Oct/08 07:05 PM
Component/s: Tools
Affects Version/s: 1.0
Fix Version/s: b21

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: All


Issuezilla Id: 383
Tags:
Participants: easarina, elnyvbo and vince kraemer


 Description  « Hide

I've used Test Agent nbms that were created by Vince on 01/11.
I've removed a Contact header from the BYE request. Then I've tried to
generate other new requests. All of them, by default, did not have the Contact
header, but originally these requests, by default, had the Contact header. I
believe that the removing of a header from one request should not affect other
requests. Cancel, Reset did not help, only when I've restarted Test Agent, this
issue gone.



vince kraemer added a comment - 18/Jan/08 11:03 AM

reset qa contact


elnyvbo added a comment - 21/Jan/08 05:34 AM

when creating a new request, the request editor will fill in default headers
based on the request that is shown in the Message Creation area of the main
screen. I suspect that area was showing the 'BYE' request at the time, which
didn't contain the Contact: header. This is how the behaviour was intended.

To create a new request containing all the default headers (including Contact,
clear the message creation area and hit 'Request'.


easarina added a comment - 24/Jan/08 04:34 PM

I'm using test agent build that was created on 01/22. I've deleted one header
from BYE request. Then clicked OK (I did not send this request). After that I
clicked on the right button Requests and selectec REGISTER request it doesn't
have the header that was removed. I've restarted the Test Agent. Then I removed
a header from REGISTER, clicked OK, clicked New Request, selected BYE, it did
not have the header that was removed.

Please fix this issue.


elnyvbo added a comment - 25/Jan/08 12:08 AM

I'm still under the impression that the behaviour you describe is how it was
designed. When you open the request editor, the test agent will try to parse the
text in the Message Creation area as a starting point. If that text does not
contain a header, neither will the request you're starting to edit.

Could you please try the following:

1. Start the test agent
2. click either "Request..." or "New Request...". The request editor opens with
a default register request.
3. Set method to BYE
4. Delete, for example, the Content-type header.
5. click OK. the request editor closes and the Message Creation area now shows a
BYE request.
6. !! ---> select the text in the Message Creation area and delete it.
7. repeat step 2. Does the register request in the request editor contain the
"Contact:" and "Content-type" headers now?


vince kraemer added a comment - 25/Jan/08 08:28 AM

This may be a UI interaction design bug then....


easarina added a comment - 25/Jan/08 02:55 PM

Yes, it to execute step 6:
"6. !! ---> select the text in the Message Creation area and delete it."

And click after that at New Request or Request and select any request, then
the deleted header will be presented.

But I believe that users should not to perform this additional not obvious
manual step. I think that New Request or Request has to clean all previous steps.


vince kraemer added a comment - 06/Feb/08 11:57 AM

I have looked at the code and UI a bit more, so I have some recommendations.
Please evaluate them.

1. The buttons on the right side should only be enabled IF there is a message
selected in the Message history window.

2. The semantics of 'Request...'. The request will be based on the text of the
selected message. If messageA doesn't have a header... messageB created from it
won't either.

3. 'New Request' will always start a new message. It will NOT be based on the
content of the message prep area... This may mean that we need to add a state
variable for the 'sent'-ness of the message in the prep area. This would allow
us to warn the user that the message in the prep area is in danger of being
overwritten.

4. We may need to add an Edit Current button under the message prep area...
This would allow folks to use the structured editor on an unsent message. This
button would be disabled when the message prep area is empty....


elnyvbo added a comment - 07/Feb/08 01:17 AM

good points, my evaluation:

1. agreed.
2. correct, this is intended behaviour.
3. imho adding another button may only complicate things. Note that this would
be the third button to open the structured request editor.
4. Actually this "Edit Current" button is what is currently the "New Request..."
button. Why don't we just change the current label to "Edit Current" – maybe it
would invite the user to delete the text if he wanted to start afresh?


vince kraemer added a comment - 11/Feb/08 04:18 PM

small change: the rightside buttons will not enable and disable based on whether
a message is selected in the history window... their initial state would be
disabled... which is always a strange state to be in...

I will add an error dialog to tell the user what is wrong if they press the
button too early...


vince kraemer added a comment - 11/Feb/08 06:49 PM

changes made...

1. added warning dialog to ack,bye, cancel,request,response and copy message
buttons.
2. New Request button changes to Edit Current if there is content in "Compose
message area.

http://fisheye5.cenqua.com/changelog/sailfin/?cs=MAIN:vbkraemer:20080212011226


vince kraemer added a comment - 11/Feb/08 06:53 PM

forgot to change the TM