sailfin
  1. sailfin
  2. SAILFIN-387

Hardcoded paths in self build SailFin jar installer

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: milestone 1
    • Component/s: build_system
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: All

    • Issuezilla Id:
      387

      Description

      When following the instruction how to build SailFin jar installer from the
      https://sailfin.dev.java.net/Build_Instructions_for_SailFin.html it is
      impossible to install the created sailfin-installer.jar on another machine.
      The problem is that during the building process the paths from the build server
      are being hardcoded into the SailFin installation environment. The whole path
      setup is identical as the one that was defined on the build server. This can be
      visible when examining the contents of the asenv.conf file. During the
      installation the jar files and another component cannot be found on the machine
      where SailFin is being installed due to the fact that directory stucture on
      that machine is different than the one on build server.
      This issue makes it impossible to create a working SailFin build by following
      the steps as described on
      https://sailfin.dev.java.net/Build_Instructions_for_SailFin.html.
      Promoted builds don't have this problem and they install without any issues on
      any machine in the lab.

        Activity

        misiozor added a comment -

        After solving the problems with paths it appeares that it is further not
        possible to create a cluster using this SailFin installation even though
        SailFin has been installed using ant -f setup-cluster.xml option. The asadmin
        responds on the attempts to create a cluster in the following way:
        ===================
        ~>./bin/asadmin create-cluster test-cluster
        This operation failed, because it could not be handled by this domain.
        An example of such an operation is creating application server instances or
        clusters when they are not supported by the given domain.
        The actual error is: MBean instance not found:
        com.sun.appserv:type=clusters,category=config
        CLI137 Command create-cluster failed.
        ===================

        misiozor added a comment -

        Skipping step number 11 i.e. "maven configure-runtime" from the build
        instruction and proceeding directly to step number 12 i.e. "maven build-
        jarinstaller" allows to create an installabe jar file that would install on any
        machine and thus solves the problem that I described above.

        I'd suggest therefore to add suitable comment on the
        https://sailfin.dev.java.net/Build_Instructions_for_SailFin.html page to avoid
        confusion.

        misiozor added a comment -

        Skipping step number 11 i.e. "maven configure-runtime" from the build
        instruction and proceeding directly to step number 12 i.e. "maven build-
        jarinstaller" allows to create an installabe jar file that would install on any
        machine and thus solves the problem that I described above.

        I'd suggest therefore to add suitable comment on the
        https://sailfin.dev.java.net/Build_Instructions_for_SailFin.html page to avoid
        confusion.

        naman_mehta added a comment -

        Updated buid instruction to resolve this error.

        misiozor added a comment -

        Thanks!


          People

          • Assignee:
            naman_mehta
            Reporter:
            misiozor
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: