sailfin
  1. sailfin
  2. SAILFIN-875

Old windows.timestamp is downloaded

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: milestone 1
    • Component/s: build_system
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      For maven goal build-latest the content of
      http://70.42.188.20/snapshot/WINNT/windows.timestamp
      tells which sailfin-image that should be downloaded. However when running that
      target behind ericsson http proxy an old version is returned from the proxy
      server. This may be a bug or a setting in the http proxy used. A workaround for
      the problem is to include the
      Pragma: no-cache
      header in the GET request.

      To prove mu point I did the following

      A. run maven bootstrap-latest (I do unfortunately not have a trace for this)
      =>An old version of the snapshot is used.

      B. browse to http://70.42.188.20/snapshot/WINNT/windows.timestamp
      => Since I had a cached version in my browser cache that one is displayed

      C. Hit CTRL-SHIFT + reload in the browser
      => This issues a GET request with Pragma: no-cache that the proxy server seems
      to respect. A new version of the timestamp is downloaded and as a side
      effect the cached item in the proxy server is replaced.

      D. run maven bootstrap-latest
      Now a new version of the time stamp is downloaded and used.

      B and C are captured in the 'browser.pcap' attachment
      D is captured in the 'second_bootstrap_latest.pcap' attachment

      Proposition:
      In the build system send a GET request with "Pragma: no-cache" to
      http://70.42.188.20/snapshot/WINNT/windows.timestamp, either as part of fetching
      the timestamp file, or before doing that just to refresh the proxy caches
      between the build system and the origin server.

      This problem is a real problem when rebuilding inside Ericsson. We don't want
      to develop and test agains an old snapshot. The only reason for me not to set
      this to a P2 is that there is a workaround: hit CTRL+SHIFT in the browser when
      surfed to 'http://70.42.188.20/snapshot/WINNT/windows.timestamp'.

      1. browser.pcap
        2 kB
        qmaghes
      2. second_bootstrap_latest.pcap
        8 kB
        qmaghes

        Activity

        naman_mehta added a comment -

        Still you are facing this problem. Please confirm me.

        qmaghes added a comment -

        I did face the problem in July. Today I couldn't reproduce it, but it doesn't
        mean that the problem is gone. It is sufficient that someone behind the same
        proxy as I am has managed to get the "latest" version of the
        linux.timestamp /windows.timestamp into the proxy cache and everything will
        work correctly until the next build is made.

        naman_mehta added a comment -

        Added configuration on tomcat server for removing proxy cache.

        <context><Valve className="org.apache.catalina.authenticator.BasicAuthenticator"
        disableProxyCaching="false" /></context>

        qmaghes added a comment -

        Adrian got this problem again today. The returned windows.timestamp was old.

        naman_mehta added a comment -

        I don't find any option for no-cache in ant during download so updated
        configuration setting in tomcat for no-cache. Please check and let me know.


          People

          • Assignee:
            naman_mehta
            Reporter:
            qmaghes
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: