shoal
  1. shoal
  2. SHOAL-46

.shoal directory size increases dangerously

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: GMS
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: OpenSolaris

    • Issuezilla Id:
      46

      Description

      Hi from Sweden,

      After sending a number of GMS messages, i found out that there is a catalog
      named .shoal in the locatio where i run the JVM.
      This catalog i several cases exceeded 300 MBs in size which may lead to fill the
      file system.

      Please note that i am testing shoal on java 6 patch 4, using the libraries from
      sailfin v1 b22, not sailfin.

      BR

      Babbis

        Activity

        sheetalv added a comment -

        Thanks for filing this issue. I will look into this issue asap.

        shreedhar_ganapathy added a comment -

        While we investigate this issue, could you try the latest shoal and jxta jars
        that have now been integrated into Sailfin build 24a. For your reference, the
        following contains those specific jars :
        https://shoal.dev.java.net/files/documents/5135/89898/shoal-1.1_03132008.zip

        shreedhar_ganapathy added a comment -

        Hi Babbis,
        While we investigate this issue, could you try the latest shoal and jxta jars
        that have now been integrated into Sailfin build 24a. For your reference, the
        following contains those specific jars :
        https://shoal.dev.java.net/files/documents/5135/89898/shoal-1.1_03132008.zip

        Thanks
        Shreedhar

        shreedhar_ganapathy added a comment -

        Based on the following email from Babbis, the issue is resolved with the 1.1 bits
        ==
        Hi,

        This fix worked fine ! No file leaks were after heavy traffic.
        I have tested the fix on v1-b25.

        Thanks

        Babbis
        ==


          People

          • Assignee:
            sheetalv
            Reporter:
            babbisx
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: