shoal
  1. shoal
  2. SHOAL-47

Gracefully shutdown does not work, but also creates sideeffects

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: GMS
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: OpenSolaris

    • Issuezilla Id:
      47

      Description

      Hi from Sweden,

      I found out that GMS gracefull shutdown,

      //leaves the group gracefully
      gms.shutdown(GMSConstants.shutdownType.INSTANCE_SHUTDOWN);

      does not work, but also has some serious sideeffects :

      • first i get an exception

      Exception in thread "MessageWindowThread" java.lang.NullPointerException
      at
      com.sun.enterprise.ee.cms.impl.jxta.MessageWindow.run(MessageWindow.java:86)
      at java.lang.Thread.run(Thread.java:619)

      • afterwards, all other group members will see the member that called shutdown()
        permanently in the group member list . This means that the member will appear
        in member list for ever (until all members and their processes terminate).

      This have been verified both though out prints and by calling

      List<String> members = groupHandle.getAllCurrentMembers();

      On the other hand if the members JVM terminates (not gracefull shutdown) the
      member is correctly removed.

      Please note that this is verified on java 6 patch 4 and the libraries from
      sailfin v1 b22. Please also note that i am not running sailfin/glassfish, just
      plain JVM.

      BR

      Babbis

        Activity

        sheetalv added a comment -

        This issue has already been filed under issue 48.

            • This issue has been marked as a duplicate of 48 ***
        sheetalv added a comment -

        This issue has been reopened to track the second part of the description.

        shreedhar_ganapathy added a comment -

        Based on the following email snippet from Babbis, the issue is resolved with the
        1.1 bits
        ==
        The problem with gratefull shutdow were apparent in pure v1-b25, but were fixed
        when the pach were applyied.
        (this was actually a big issue when we e g wanted to replace cards in a cluster
        and the subscriber on the removed server instance where never removed from the
        group).
        So you can remove issue 48 also.

        ==


          People

          • Assignee:
            shreedhar_ganapathy
            Reporter:
            babbisx
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: