sipservlet-spec
  1. sipservlet-spec
  2. SIPSERVLET_SPEC-11

Optimize application composition for intra-container routing of requests

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: None
    • Fix Version/s: 2.0-pr
    • Labels:
      None

      Description

      Application Router functionality in SIP Servlet 1.1 end up incurring performance issues, even when the requests are chained or routed within the container. So, the application router functionality should be updated to optimize the intra-container routing of the requests.

        Activity

        binod created issue -
        binod made changes -
        Field Original Value New Value
        Assignee binod [ binod ]
        binod added a comment -

        https://java.net/projects/sipservlet-spec/lists/jsr359-experts/archive/2013-08/message/12

        We decided that the application composition optimization can actually be done already by the
        containers. We also figured a case of a specific behavior of JSR 289 preventing an optimization
        as described in the email below.

        https://java.net/projects/sipservlet-spec/lists/jsr359-experts/archive/2013-08/message/20

        The issue has since been resolved by depending RFC 6026 for handling retransmissions and modified text is available
        in 12.2.4.1

        There was a proposal for introducing a SipApplicationChainScoped CDI context in the v0.6 of the spec (23.4.5.3 of https://java.net/downloads/sipservlet-spec/v0.6/jsr359-v06.pdf) to store composition wide objects. We decided not to pursue this, since some EG members expressed
        concerns on the complexity it is bringing in. In any case that was not addressing any container performance related to composition.

        binod made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.0-pr [ 16895 ]
        Resolution Works as designed [ 7 ]

          People

          • Assignee:
            binod
            Reporter:
            binod
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: