svgsalamander
  1. svgsalamander
  2. SVGSALAMANDER-10

When a SVG element ('style') has a element 'marker-start:none' I got multiple FileNotFoundExceptions

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: None
    • Component/s: www
    • Labels:
      None

      Description

      When a SVG element ('style') has a element 'marker-start:none' (for example when I create a SVG file with Inkscape). I got multiple java.io.FileNotFoundExceptions the url ends with none.

      It seems that there is no problem with rendering the svg.

      Stack Trace:

      java.io.FileNotFoundException: http://localhost/Java_Applet/04-SVG/svgExample/none
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
      at java.net.URL.openStream(Unknown Source)
      at com.kitfox.svg.SVGUniverse.loadSVG(SVGUniverse.java:436)
      at com.kitfox.svg.SVGUniverse.getElement(SVGUniverse.java:328)
      at com.kitfox.svg.SVGUniverse.getElement(SVGUniverse.java:291)
      at com.kitfox.svg.ShapeElement.renderShape(ShapeElement.java:241)
      at com.kitfox.svg.Path.render(Path.java:94)
      at com.kitfox.svg.Group.render(Group.java:196)
      at com.kitfox.svg.Group.render(Group.java:196)
      at com.kitfox.svg.SVGRoot.render(SVGRoot.java:290)
      at com.kitfox.svg.SVGDiagram.render(SVGDiagram.java:94)
      at com.kitfox.svg.SVGDisplayPanel.paintComponent(SVGDisplayPanel.java:122)
      at javax.swing.JComponent.paint(Unknown Source)
      at javax.swing.JComponent.paintChildren(Unknown Source)
      at javax.swing.JComponent.paint(Unknown Source)
      at javax.swing.JViewport.paint(Unknown Source)
      at javax.swing.JComponent.paintChildren(Unknown Source)
      at javax.swing.JComponent.paint(Unknown Source)
      at javax.swing.JComponent.paintChildren(Unknown Source)
      at javax.swing.JComponent.paint(Unknown Source)
      at javax.swing.JComponent.paintChildren(Unknown Source)
      at javax.swing.JComponent.paint(Unknown Source)
      at javax.swing.JLayeredPane.paint(Unknown Source)
      at javax.swing.JComponent.paintChildren(Unknown Source)
      at javax.swing.JComponent.paintToOffscreen(Unknown Source)
      at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
      at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
      at javax.swing.RepaintManager.paint(Unknown Source)
      at javax.swing.JComponent.paint(Unknown Source)
      at java.awt.GraphicsCallback$PaintCallback.run(Unknown Source)
      at sun.awt.SunGraphicsCallback.runOneComponent(Unknown Source)
      at sun.awt.SunGraphicsCallback.runComponents(Unknown Source)
      at java.awt.Container.paint(Unknown Source)
      at java.awt.Window.paint(Unknown Source)
      at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
      at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
      at javax.swing.RepaintManager.seqPaintDirtyRegions(Unknown Source)
      at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
      at java.awt.event.InvocationEvent.dispatch(Unknown Source)
      at java.awt.EventQueue.dispatchEvent(Unknown Source)
      at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
      at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
      at java.awt.EventDispatchThread.run(Unknown Source)

        Activity

        tvdberg added a comment -

        This bug is resolved in the newest version from subversion: svn/trunk/www/binaries/svgSalamander.jar. I suppose that this bug is a duplicate of bug svgsalamander-9.

        kitfox added a comment -

        Fixed.


          People

          • Assignee:
            Unassigned
            Reporter:
            tvdberg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: