swinglabs
  1. swinglabs
  2. SWINGLABS-61

Enhance ColumnControlButton popup with separator

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: screenshots
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      61

      Description

      We use the following code to add custom JXTable actions that can be invoked by user when ColumnControlButton is clicked:

      JXTable.getActionMap().put(ColumnControlButton.COLUMN_CONTROL_MARKER + "x1_sorted_by",
      new AbstractAction("Action") {
      public void actionPerformed(ActionEvent e)

      { ... }

      });

      Is it possible to enhance the popup to:
      1. Sort custom actions independently and always place them after standard table actions?
      2. Create a separator after standard actions to visually delimit custom application
      actions? Like a separator that is already there after column list and 'Horizontal scroll'
      action.

      • it is not possible to submit the issue without selecting a Subcomponent, and there are
        only two available: screenshots and www, so please don't blame me for that.

        Activity

        kleopatra added a comment -

        an admininstrative note - maybe not overly clear from our documentation:
        technical issues should be filed under the concrete subproject's issue tracker
        to be sure they are not overlooked. Could you please move this over (that is
        file there and close here) to swingx issue tracker?

        Thanks, and sorry for the inconvenience
        Jeanette

        arkadi added a comment -

        Just opened new issue with swingx component, but I can't close this one, please
        close.
        Also, http://swinglabs.org/docs/project/index.jsp:
        Subcomponent - select the subcomponent of a given component. If you're not sure,
        just select code.

        If 'code' means subcomponent, then there is no such available in swingx tracker.

        kleopatra added a comment -

        For reference: the issue is moved to

        https://swingx.dev.java.net/issues/show_bug.cgi?id=968

        thanks for taking the trouble!
        Jeanette

        kleopatra added a comment -

        okay, filed an issue to clarify the reporting instructions:

        https://swinglabs.dev.java.net/issues/show_bug.cgi?id=62

        Thanks again!
        Jeanette


          People

          • Assignee:
            rbair
            Reporter:
            arkadi
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: