swingx
  1. swingx
  2. SWINGX-1344

Adding PromptSupport removes AntiAliasing

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 1.6.2
    • Fix Version/s: 1.6.3
    • Component/s: Misc Component
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,344

      Description

      Adding simple PromptSupport to a JTextArea disables AntiAliasing

      PromptSupport.init("Enter...", Color.BLUE, Color.BLACK, textArea);

      If I comment out that line - I have nice AntiAliased text in My TextArea,
      however if I turn on the prompt support - I get clunky text rendered

        Activity

        Karl Schaefer added a comment -

        Marking invalid per reporter; not a SwingX issue.

        aloleary added a comment -

        Hello.. I dug into this and it is a Substance issue - NOT SwingX

        For anyone interested:

        Unfortunately Substance is now 'parked' and does not look like this will be
        resolved in Substance

        Details:

        https://substance.dev.java.net/servlets/ReadMsg?list=users&msgNo=1546

        Happy for you to close this

        Karl Schaefer added a comment -

        Can you give me an update on this? Is this a SwingX issue?

        aloleary added a comment -

        OK I think I might have found something.

        I think it's not SwingX bug an interaction between SwingX and my Look and Feel
        (Substance)

        I will verify with the Substance developer

        Karl Schaefer added a comment -

        Can you please see if the problem is reproducible on Win XP? I don't have
        access to a Vista machine. Hopefully this is not OS-specific.

        aloleary added a comment -

        Specifically here:

        Vista SP2
        Java(TM) SE Runtime Environment (build 1.6.0_20-b02)

        I can test on other OS's if required

        Karl Schaefer added a comment -

        What OS and Java version?

        aloleary added a comment -

        Sorry I should have been more clear.

        The Prompt Text looks ok...

        But the Text on the TextArea itself is Aliased.

        A test case could be hard as I dont know of a way of testing the rendering
        quality but it really is a very simple case of:

        JTextArea ta = new JTextArea();
        ta.setText("Hello World");

        // On a machine that supports AntiAliasing + JDK 6 this will render with
        AntiAliasing by default as AWT picks up by default

        Simply adding the following line

        JTextArea ta = new JTextArea();
        PromptSupport.init("Enter...", Color.BLUE, Color.BLACK, ta );

        // you will now see the Enter... prompt correctly. But when you type text in the
        text area - it will be Aliased

        Karl Schaefer added a comment -

        Clunky for the promt or clunky for the text entered by the user?

        Can you provide a test case?


          People

          • Assignee:
            Karl Schaefer
            Reporter:
            aloleary
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: