swingx
  1. swingx
  2. SWINGX-1351

Clicking on JXTable column with Checkbox causes nullpointerexception

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 1.6.1
    • Fix Version/s: 1.6.3
    • Component/s: Table
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: All

    • Issuezilla Id:
      1,351

      Description

      After creating a JXTable with a default highlighter and a boolean value column,
      then I click the column with the checkbox and it causes a nullpointerexception.
      After debugging for awhile I observed that the method setBorder() from
      JComponent after callin border.getBorderInsets(this) is returning null.

      Stacktrace:

      java.lang.NullPointerException
      at javax.swing.JComponent.setBorder(JComponent.java:1768)
      at
      org.jdesktop.swingx.renderer.DefaultVisuals.configureBorder(DefaultVisuals.java:
      226)
      at
      org.jdesktop.swingx.renderer.DefaultVisuals.configureVisuals(DefaultVisuals.java
      :110)
      at
      org.jdesktop.swingx.renderer.ComponentProvider.configureVisuals(ComponentProvide
      r.java:308)
      at
      org.jdesktop.swingx.renderer.ComponentProvider.getRendererComponent(ComponentPro
      vider.java:176)
      at
      org.jdesktop.swingx.renderer.DefaultTableRenderer.getTableCellRendererComponent(
      DefaultTableRenderer.java:169)
      at javax.swing.JTable.prepareRenderer(JTable.java:5735)
      at org.jdesktop.swingx.JXTable.prepareRenderer(JXTable.java:3545)
      at javax.swing.plaf.synth.SynthTableUI.paintCell(SynthTableUI.java:636)
      at javax.swing.plaf.synth.SynthTableUI.paintCells(SynthTableUI.java:533)
      at javax.swing.plaf.synth.SynthTableUI.paint(SynthTableUI.java:322)
      at javax.swing.plaf.synth.SynthTableUI.update(SynthTableUI.java:251)
      at javax.swing.JComponent.paintComponent(JComponent.java:765)
      at javax.swing.JComponent.paint(JComponent.java:1029)
      at javax.swing.JComponent.paintToOffscreen(JComponent.java:5138)
      at
      javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:302
      )
      at javax.swing.RepaintManager.paint(RepaintManager.java:1145)
      at javax.swing.JComponent._paintImmediately(JComponent.java:5086)
      at javax.swing.JComponent.paintImmediately(JComponent.java:4896)
      at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:740)
      at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:696)
      at
      javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:676)
      at javax.swing.RepaintManager.access$700(RepaintManager.java:57)
      at
      javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1550)
      at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
      at
      org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:137)
      at
      java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275
      )
      at
      java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
      at
      java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190
      )
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
      [catch] at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

        Activity

        Karl Schaefer added a comment -

        Sounds like a duplicate of Issue 1297.

        I am guessing that the workaround; doesn't work. Can you confirm if this is a
        duplicate and provide more detail regarding the border issue.

        kleopatra added a comment -

        looks like a duplicate to me, so closing this. @Karl, how's the status of the other issue?
        Added a handful of comments a while ago

        CU
        Jeanette

            • This issue has been marked as a duplicate of 1297 ***

          People

          • Assignee:
            kleopatra
            Reporter:
            andvicoso
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: