Issue Details (XML | Word | Printable)

Key: SWINGX-1361
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Blocker Blocker
Assignee: Karl Schaefer
Reporter: atellezflores
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
swingx

Problem in JXPromptBeanInfo

Created: 21/Oct/10 06:46 AM   Updated: 28/Jan/11 01:08 PM   Resolved: 01/Nov/10 05:57 AM
Component/s: Misc Component
Affects Version/s: 1.6.2
Fix Version/s: 1.6.3

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: Macintosh
URL: http://forums.java.net/jive/thread.jspa?threadID=154106&tstart=0


Issuezilla Id: 1,361
Tags:
Participants: atellezflores and Karl Schaefer


 Description  « Hide

It rised in NetBeans 6.9.1 UI designer, after some research I found this problem,

It uses
org.jdesktop.xwingx.prompt.PromptSupport.FocusBehavior.SHOW_PROMPT

instead of

org.jdesktop.swingx.prompt.PromptSupport.FocusBehavior.SHOW_PROMPT

The problem is that it switches 's' with an 'x'. I've found it in this URL, although it's reported on version
1.6.1, the problem rised when I switched to 1.6.2 in Netbeans 6.9.1

http://www.jarvana.com/jarvana/view/org/swinglabs/swingx/1.6.1/swingx-1.6.1-
sources.jar!/org/jdesktop/swingx/JXPromptBeanInfo.java?format=ok



Karl Schaefer added a comment - 27/Oct/10 09:25 AM

Issue 1361: Fix typo in BeanInfo.

swingx-beaninfo/src/main/java/org/jdesktop/swingx/JXPromptBeanInfo.java

Committed revision 3867.


kenaiadmin made changes - 25/Jan/11 02:05 PM
Field Original Value New Value
issue.field.bugzillaimportkey 1361 85621
Karl Schaefer made changes - 28/Jan/11 01:08 PM
Affects Version/s 1.6.2 [ 13362 ]
Affects Version/s 1.6.1++ [ 13361 ]