swingx
  1. swingx
  2. SWINGX-1446

JXCollapsiblePane fails to use alpha settings

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.6.2
    • Fix Version/s: 1.6.3
    • Component/s: Table
    • Labels:
      None

      Description

      This has been broken since SVN revision 2417, where we fixed SWINGX-348, SWINGX-495, and SWINGX-525. The supplied change does not correctly paint with an alpha.

      I'd mark this as a regression and a blocker, but since no one has complained in almost four years, I don't think it is that critical.

        Activity

        Karl Schaefer added a comment -

        SWINGX-1446: Fixed the alpha painting issue. Verified via visual inspection of JXCollapsiblePaneVisualCheck.

        swingx-core/src/main/java/org/jdesktop/swingx/JXCollapsiblePane.java

        Committed revision 4025.


          People

          • Assignee:
            Karl Schaefer
            Reporter:
            Karl Schaefer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: