swingx
  1. swingx
  2. SWINGX-149

Localized strings are commented out in the JXLoginDialog

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.9.0
    • Component/s: Authentication
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      149

      Description

      While the JXLoginPanel extracts its strings from the UIManager to allow
      localization the JXLoginDialog commented out these lines.
      This might be my fault when I rewrote portions of this code that Richard
      refactored later.

      1. JXLoginDialog.java
        14 kB
        vprise
      2. resources.properties
        0.4 kB
        vprise

        Activity

        vprise added a comment -

        Created an attachment (id=26)
        Updated resources to cover all strings in the login dialog

        vprise added a comment -

        Created an attachment (id=27)
        Fix for the localized strings it also includes the component orientation fixes

        vprise added a comment -

        I attached a fix for this issue and now the dialog looks great in Hebrew as
        well. One thing to keep in mind is that since my code includes the bidi fixes I
        made this fix includes two separate changes: localization AND bidi fixes. Both
        should probably be applied though

        kleopatra added a comment -


        changed priority to p2 - bidi/localization issues should be fixed for final 1.0

        vprise added a comment -
            • Issue 122 has been marked as a duplicate of this issue. ***
        vprise added a comment -

        Commited fix to CVS


          People

          • Assignee:
            rbair
            Reporter:
            vprise
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: