swingx
  1. swingx
  2. SWINGX-1527

JXTreeTable tooltips not shown after expand/collapse tree

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6.4
    • Fix Version/s: 1.6.5
    • Component/s: TreeTable
    • Labels:
      None
    • Environment:

      Archlinux
      Windows 7
      Java 1.7.0_07

      Description

      Tooltips are shown after expanding or collapsing tree and not moving the mouse out of the bounds of the rows in the table

      Exact steps to reproduce using both a linux and windows environment and java 1.7.0_07
      I have attached a small runnable example

      1. Hold mouse over any cell and the tooltip is displayed
      2. Click the tree icon so the tree collapses and then click again so the tree expands again.
      3. Now without leaving the bounds of the table (not moving the mouse out of the rows) move the mouse to any cell, the tooltip no longer gets displayed
      4. Move the mouse out of the table bounds to anywhere on the screen
      5. Move mouse back over the table, tooltips are now displayed again

      I stress that this only happens when after the tree expandsion/collapse click the mouse must not move off any row otherwise the tooltips work again correctly

      Have also tried using ToolTipHighlighter and get the same results

        Activity

        kleopatra added a comment -

        thanks for filing (somehow it seems to be known - as documented in JXTreeTableVisualCheck.interactiveHierarchicalToolTip - but got forgotten)

        Need to dig a bit to find the reason.

        Jeanette

        kleopatra added a comment -
        • added/commented tests to expose)
        • fixed (loosely related) issue (fixed tooltip on treeTable not propagated to the rendering tree)
        kleopatra added a comment -

        The problem is TreeTableHacker4/5: they pass all pressed/clicked/released events in the handle area to the tree plus disabling processMouseMotion for the table. Re-enabling isn't guaranteed, need to find a way to do so without sacrificing the hacked bugs ...

        Not overly enthusiastic, though: piling hack-on-hack in a mile-high pile is .. most probably introducing other bugs somewhere else.

        kleopatra added a comment -

        "fixed" (aka: yet another hack on top of the pile as of revision #4256

        • hacked by hacking TreeTableHackerExt4
        • was: when routing a mouseEvent to the rendering tree, mouseMotionProcessing on the table was disabled without reliably enabling it again

        Please let me know how it goes

        Thanks
        Jeanette


          People

          • Assignee:
            kleopatra
            Reporter:
            oneandonlyluppy
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: