swingx
  1. swingx
  2. SWINGX-1528

JXTable does not allow negative float values to be entered

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.6.4
    • Fix Version/s: 1.6.5
    • Component/s: Table
    • Labels:
      None
    • Environment:

      Windows 7
      jdk1.6.0_32

      Description

      JXTable does not allow user to enter negative float values or 0.

      This issue seems to occur only when the column class is of type Float.class. It does not occur when Double.class or Number.class is used. I could not reproduce this issue with JTable.

      I've attached a runnable demo.

        Activity

        kleopatra added a comment -

        uppened priority

        kleopatra added a comment -

        fixed as of revision #4245

        • error was incorrect float min in StrictNumberFormatter
        • fixed to use -Float.MAX_VALUE (not entirely if that's correct?)
        • added/updated tests

        Thanks for filing, especially happy about the attached runnable example


          People

          • Assignee:
            kleopatra
            Reporter:
            Ramesses
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: