swingx
  1. swingx
  2. SWINGX-367

JavaBean vetoable property changes are defeated by serialization

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.9.0
    • Component/s: Misc Component
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      367

      Description

      According to the Javadoc for VetoableChangeSupport,

      • This is a utility class that can be used by beans that support constrained
      • properties. You can use an instance of this class as a member field
      • of your bean and delegate various work to it.
        *
      • This class is serializable. When it is serialized it will save
      • (and restore) any listeners that are themselves serializable. Any
      • non-serializable listeners will be skipped during serialization.

      But JavaBean defines VetoableChangeSupport as transient so the change vetoes are destroyed when an
      instance is serialized.

        Activity

        kleopatra added a comment -


        Richard's babe

        Karl Schaefer added a comment -

        368 is an identical report, but contains more information.

            • This issue has been marked as a duplicate of 368 ***

          People

          • Assignee:
            rbair
            Reporter:
            jessewilson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: