Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.9.0
    • Component/s: Misc Component
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      510

      Description

      Environment:
      Swingx 2007/05/01, Linux x86 32, JRE 1.6 Sun

      Description
      JXPanel panel = new JXPanel();
      panel.setBackgroundPainter(new MattePainter(PaintUtils.AERITH));

      displays no gradient but an uniform blue (regression from removed
      BasicGradierntPainter class)

      Workaround:
      Setting Point2D Y value in PaintUtils.AERITH to, say, 1000 instead of 1 works
      but doesn't take the panel current size into account.

        Activity

        kleopatra added a comment -


        Richard is the expert here

        osbald added a comment -

        No really? your too kind (it's not me). Isn't this a common mistake from
        BasicGradientPainter whereby the paint needs to be stretched?
        BasicGradientPainter was strechy but MattePainter isn't by default.

        i.e. mattePainter.setPaintStretched(true);

        Might be worth an enhancement to either reconsider the defaults or add another
        constructor / painter class as it's a PITA to assign to a local var just to set
        the property.

        rah003 added a comment -

        Well this is not a bug really. We have a constructor for MattePainter which
        makes it stretched by default. Just use it.
        panel.setBackgroundPainter(new MattePainter(PaintUtils.AERITH, true));


          People

          • Assignee:
            rbair
            Reporter:
            bflorat
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: