swingx
  1. swingx
  2. SWINGX-560

Then both UserNameStore and PasswordStore are provided, then the save mode is set to the both. The JXLogin panel listener onto success login saves passwords not usernames

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.9.0
    • Component/s: Authentication
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      560

      Description

      protected class LoginListenerImpl extends LoginAdapter {
      public void loginSucceeded(LoginEvent source) {
      //save the user names and passwords
      String userName = namePanel.getUserName();
      savePassword();
      if (getSaveMode() == SaveMode.USER_NAME
      && userName != null && !userName.trim().equals(""))

      { userNameStore.addUserName(userName); userNameStore.saveUserNames(); }

      setStatus(Status.SUCCEEDED);
      }
      .....

      the savePassword() process SaveMode.BOTH correctly, but
      loginSucceeded() function should change
      >> if (getSaveMode() == SaveMode.USER_NAME)
      to something like
      >> if ( (getSaveMode() == SaveMode.USER_NAME) || (getSaveMode() ==
      SaveMode.BOTH)) ...

        Activity

        leonardinius added a comment -

        i could implement this myself, just don't know how to participate in project.
        i have locally made some dirty patches (could be reviewed or smth..)

        please, point me some information about participation project.
        PS. sorry for not using google (only found http://java.net/terms.csp in 10 secs )

        Karl Schaefer added a comment -

        This appears to be a duplicate of 455. I will take and start on 455.

            • This issue has been marked as a duplicate of 455 ***

          People

          • Assignee:
            vprise
            Reporter:
            leonardinius
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: