Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.9.0
    • Fix Version/s: 0.9.0
    • Component/s: Calendar
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      71

      Description

      When running stress tests using Jemmy I get the following exception. From
      reviewing the code it really isn't clear to me what causes this exception:
      Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
      at javax.swing.ImageIcon.<init>(ImageIcon.java:138)
      at org.jdesktop.swingx.calendar.JXMonthView.updateUI(Unknown Source)
      at org.jdesktop.swingx.calendar.JXMonthView.<init>(Unknown Source)
      at org.jdesktop.swingx.calendar.JXMonthView.<init>(Unknown Source)
      at org.jdesktop.swingx.JXDatePicker.<init>(Unknown Source)
      at org.jdesktop.swingx.JXDatePicker.<init>(Unknown Source)

      The code seems fine in general and it works correctly when running without Jemmy.

        Activity

        kleopatra added a comment -


        assigned date/month picker related issues to Joshua.

        dmouse added a comment -

        Please recompile the project with debug enabled so you get source code lines in it. Without these the
        stack trace isn't helpful. It is probably one of the images returning null, but without the line number and a
        reproducible test case I don't know which one.

        vprise added a comment -

        Its been so long I don't remeber how I got this issue...
        Leave it assigned to me and when I get back from my trip I will try to reproduce
        this, it should probably be in the beginning of November.

        kleopatra added a comment -

        cleanup: subcomponent

        vprise added a comment -

        I tried to reproduce it with my current tests but the code that caused this
        failure is probably long gone. I marked it as works for me and in the future if
        someone sees something of this type please reopen this bug and try to detect the
        exact line.


          People

          • Assignee:
            vprise
            Reporter:
            vprise
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: