swingx-ws
  1. swingx-ws
  2. SWINGX_WS-17

GeoPosition implements equals but not hashCode

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: initial
    • Fix Version/s: 1.1
    • Component/s: www
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      17

      Description

      org.jdesktop.swingx.mapviewer.GeoPosition implements equals but not hashCode.

      The result is that GeoPosition when used in a java.util.Set causes Set to behave
      incorrectly (inserting multiple equivalent positions results in a Set with
      multiple equivalent positions).

      Problem still exists in CVS as of Jan 6, 2009

        Activity

        bshelden added a comment -

        Created an attachment (id=1)
        Test case demonstrating GeoPosition used in a Set

        rah003 added a comment -

        Bumped to the next version.

        Karl Schaefer added a comment -

        Duplicate of SWINGX_WS-39, keeping that because of the patch.


          People

          • Assignee:
            Unassigned
            Reporter:
            bshelden
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: