TrueZIP
  1. TrueZIP
  2. TRUEZIP-285

NoSuchMethodError: de.schlichtherle.truezip.file.TConfig.getFsManager()Lde/schlichtherle/truezip/fs/FsManager;

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: TrueZIP 7.5.5
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Hello,

      One of my users reported the following crash:

      program.name=DocFetcher
      program.version=1.1.1
      program.build=20120815-1733
      java.runtime.name=Java(TM) SE Runtime Environment
      java.runtime.version=1.6.0_33-b05
      java.version=1.6.0_33
      sun.arch.data.model=32
      os.arch=x86
      os.name=Windows XP
      os.version=5.1
      user.language=en
      java.lang.NoSuchMethodError: de.schlichtherle.truezip.file.TConfig.getFsManager()Lde/schlichtherle/truezip/fs/FsManager;
      at de.schlichtherle.truezip.file.TVFS.sync(TVFS.java:284)
      at de.schlichtherle.truezip.file.TVFS.sync(TVFS.java:231)
      at de.schlichtherle.truezip.file.TVFS.umount(TVFS.java:82)
      at net.sourceforge.docfetcher.model.index.file.FileIndex$1.runFinally(FileIndex.java:402)
      at net.sourceforge.docfetcher.util.Stoppable.run(Stoppable.java:59)
      at net.sourceforge.docfetcher.model.index.file.FileIndex.visitDirOrZip(FileIndex.java:272)
      at net.sourceforge.docfetcher.model.index.file.FileIndex.access$200(FileIndex.java:50)
      at net.sourceforge.docfetcher.model.index.file.FileIndex$1.handleDir(FileIndex.java:383)
      at net.sourceforge.docfetcher.model.index.file.HtmlFileLister.runWithHtmlPairing(HtmlFileLister.java:144)
      at net.sourceforge.docfetcher.model.index.file.HtmlFileLister.doRun(HtmlFileLister.java:56)
      at net.sourceforge.docfetcher.util.Stoppable.run(Stoppable.java:57)
      at net.sourceforge.docfetcher.model.index.file.FileIndex.visitDirOrZip(FileIndex.java:272)
      at net.sourceforge.docfetcher.model.index.file.FileIndex.access$200(FileIndex.java:50)
      at net.sourceforge.docfetcher.model.index.file.FileIndex$1.handleDir(FileIndex.java:383)
      at net.sourceforge.docfetcher.model.index.file.HtmlFileLister.runWithHtmlPairing(HtmlFileLister.java:144)
      at net.sourceforge.docfetcher.model.index.file.HtmlFileLister.doRun(HtmlFileLister.java:56)
      at net.sourceforge.docfetcher.util.Stoppable.run(Stoppable.java:57)
      at net.sourceforge.docfetcher.model.index.file.FileIndex.visitDirOrZip(FileIndex.java:272)
      at net.sourceforge.docfetcher.model.index.file.FileIndex.doUpdate(FileIndex.java:158)
      at net.sourceforge.docfetcher.model.TreeIndex.update(TreeIndex.java:136)
      at net.sourceforge.docfetcher.model.index.Task.update(Task.java:98)
      at net.sourceforge.docfetcher.model.index.IndexingQueue.threadLoop(IndexingQueue.java:161)
      at net.sourceforge.docfetcher.model.index.IndexingQueue.access$100(IndexingQueue.java:44)
      at net.sourceforge.docfetcher.model.index.IndexingQueue$2.run(IndexingQueue.java:116)

        Activity

        qforce added a comment -

        I've been thinking about this and the thought occurred to me that I might simply be missing some TrueZIP jars, since I was trying to keep the download size of my program low. The following jars were present:

        truezip-driver-file-7.5.5.jar
        truezip-driver-tar-7.5.5.jar
        truezip-driver-zip-7.5.5.jar
        truezip-file-7.5.5.jar
        truezip-kernel-7.5.5.jar
        truezip-swing-7.5.5.jar

        Christian Schlichtherle added a comment -

        Apparently the class path or the class loader environment is set up incorrectly. Note that some classes are loaded dynamically, so the current thread's context class loader should be able to see the classes.

        qforce added a comment -

        FYI, I found out what the problem was: Multiple incompatible versions of TrueZIP were loaded into the runtime, because jars from older program versions weren't removed during installation.

        Christian Schlichtherle added a comment -

        You're welcome!


          People

          • Assignee:
            Christian Schlichtherle
            Reporter:
            qforce
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: