TrueZIP
  1. TrueZIP
  2. TRUEZIP-326

Proper exception Message not shown upon exception (this time with Zip archive file)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: TrueZIP 7.7.2
    • Fix Version/s: TrueZIP 7.7.3
    • Component/s: TrueZIP Driver ZIP
    • Labels:
      None
    • Environment:

      with Java 7 (1.7.0_15) on MacOSx (10.7.5) with IntelliJ IDE version 12

      Description

      The data : a Zip archive consisting of 40K+ zip archives. Each of the 40K+ zip archives are comprised of two text files (an XML file and a plain text file).

      Problem : WHile processing a Zip file of zip files, upon processing 10147 files, the process throws an exception

      Exception in thread "main" java.lang.NullPointerException
          at com.trgr.rd.elasticsearch.IndexElastic.main(IndexElastic.java:76)
      java.lang.IllegalStateException: Can't overwrite predecessor!
      Disconnected from the target VM, address: '127.0.0.1:51225', transport: 'socket'
          at de.schlichtherle.truezip.io.SequentialIOException.setPredecessor(SequentialIOException.java:194)
          at de.schlichtherle.truezip.io.SequentialIOException.initPredecessor(SequentialIOException.java:184)
          at de.schlichtherle.truezip.io.SequentialIOExceptionBuilder.update(SequentialIOExceptionBuilder.java:86)
          at de.schlichtherle.truezip.io.SequentialIOExceptionBuilder.update(SequentialIOExceptionBuilder.java:22)
          at de.schlichtherle.truezip.util.AbstractExceptionBuilder.warn(AbstractExceptionBuilder.java:77)
          at de.schlichtherle.truezip.fs.FsManager.sync(FsManager.java:107)
          at de.schlichtherle.truezip.fs.FsDefaultManager.sync(FsDefaultManager.java:190)
          at de.schlichtherle.truezip.fs.FsSyncShutdownHook$Hook.run(FsSyncShutdownHook.java:93)
      Caused by: de.schlichtherle.truezip.fs.FsSyncWarningException: zip:zip:file:/Users/U0102180/data/lemur/harvest/2012-02-10.zip!/2012-02-10/3eebbcfc-1190-3bd5-b95f-f6501dbea1be__2012-02-10-03-40-32-696.zip!/
          at de.schlichtherle.truezip.fs.FsResourceController.syncResources(FsResourceController.java:98)
          at de.schlichtherle.truezip.fs.FsResourceController.sync(FsResourceController.java:72)
          at de.schlichtherle.truezip.fs.FsCacheController.sync(FsCacheController.java:178)
          at de.schlichtherle.truezip.fs.FsSyncController.sync(FsSyncController.java:234)
          at de.schlichtherle.truezip.fs.FsLockController$1Sync.call(FsLockController.java:235)
          at de.schlichtherle.truezip.fs.FsLockController$1Sync.call(FsLockController.java:232)
      
          at de.schlichtherle.truezip.fs.FsLockController.locked(FsLockController.java:328)
          at de.schlichtherle.truezip.fs.FsLockController.writeLocked(FsLockController.java:268)
          at de.schlichtherle.truezip.fs.FsLockController.sync(FsLockController.java:240)
          at de.schlichtherle.truezip.fs.archive.zip.KeyController.sync(KeyController.java:128)
          at de.schlichtherle.truezip.fs.FsDecoratingController.sync(FsDecoratingController.java:131)
          at de.schlichtherle.truezip.fs.FsFalsePositiveArchiveController.sync(FsFalsePositiveArchiveController.java:480)
          at de.schlichtherle.truezip.fs.FsManager.sync(FsManager.java:105)
          ... 2 more
      Caused by: de.schlichtherle.truezip.fs.FsResourceOpenException: Thread-local / total number of open I/O resources (streams, channels etc): 0 / 2
          at de.schlichtherle.truezip.fs.FsResourceController.syncResources(FsResourceController.java:94)
          ... 14 more
      

      Instead of throwing the reason for the actual exception, the "IllegalStateException: Can't overwrite predecessor" exception is thrown.

        Activity

        Christian Schlichtherle added a comment -

        If your application is single-threaded then could you please attach some sample data and test case? This would be really great!


          People

          • Assignee:
            Christian Schlichtherle
            Reporter:
            vayu_rw
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: