tyrus
  1. tyrus
  2. TYRUS-263

SSL via HTTP PROXY - wss://echo.websocket.org Handshake error. "Response code was not 101: 200"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: 1.3.1, 1.4
    • Component/s: client
    • Labels:
      None
    • Environment:

      windows 7 SP2

      Description

      cf. https://github.com/tyrus-project/tyrus/issues/42

      building tyrus 1.3-SNAPSHOT from commit 2e0ef56
      https://github.com/tyrus-project/tyrus/commit/2e0ef560fa8bfbfe2a73d45eb5a788309a3d6f66

      and trying the simple client described in the doc here https://tyrus.java.net/documentation/1.2.1/user-guide.html#d0e78

      against wss://echo.websocket.org

      I get a

      javax.websocket.DeploymentException: Handshake error.
      Caused by: org.glassfish.tyrus.core.HandshakeException: Response code was not 101: 200

      my test code can be found here : https://github.com/cthiebaud/shakuntala/blob/master/src/test/java/net/aequologica/shakuntala/DocClient.java

      this used to work with previous version :

      The same DocClient.java code works fine against tyrus-1.3-SNAPSHOT build from commit
      https://github.com/tyrus-project/tyrus/commit/f1b7b4d7ec933d710cb6b26e17a637e39812b48a

        Activity

        Pavel Bucek added a comment -

        damn, I misunderstood original post, thought that working commit is newer one..

        anyway, I already have a fix, should be in current trunk (1.4-SNAPSHOT) momentarily.

        cthiebaud2 added a comment -
        Pavel Bucek added a comment -

        thanks!


          People

          • Assignee:
            Pavel Bucek
            Reporter:
            cthiebaud2
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: