tyrus
  1. tyrus
  2. TYRUS-50

BlockingBinaryTest receiving chunks out of order

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0-b14, 1.0
    • Component/s: None
    • Labels:
      None

      Description

      I had to ignore this test since it is receiving chunks of message parts in a different order than they were sent - this is because AsyncBinaryToOutputStreamAdapter spawns a new thread for each message part so the order is not guaranteed. For now I have added @Ignore to the test.

        Issue Links

          Activity

          dannycoward added a comment -

          I can't reproduce this in my own workspace, but will look into it further now I have the Hudson builds.

          I've corrected the number of threads issue. Now exactly one is spawned. I suspect this only occurs when the server calls back the client on the same callback thread it resulting from a client call.

          The same issue will hold for the BlockingTextStream and PingPong tests too.

          Pavel Bucek added a comment -

          obsolete; test needs to be updated & un@Ignored

          Pavel Bucek added a comment -

          already fixed


            People

            • Assignee:
              Pavel Bucek
              Reporter:
              Martin Matula
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: