tyrus
  1. tyrus
  2. TYRUS-69

Exception on Glassfish startup - NPE from TyrusServerConfiguration

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-b09
    • Fix Version/s: 1.0-b10
    • Component/s: None
    • Labels:
      None

      Description

      [#|2013-01-22T11:19:51.884-0500|SEVERE|glassfish 4.0|javax.enterprise.web|_ThreadID=66;_ThreadName=AutoDeployer;_TimeMillis=1358871591884;_LevelValue=1000;|WebModule[/test]Exception starting filter WebSocket filter
      java.lang.InstantiationException
          at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:135)
          at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:5290)
          at org.apache.catalina.core.StandardContext.start(StandardContext.java:5902)
          at com.sun.enterprise.web.WebModule.start(WebModule.java:696)
          at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:1041)
          at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:1024)
          at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:747)
          at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:2304)
          at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1950)
          at com.sun.enterprise.web.WebApplication.start(WebApplication.java:140)
          at org.glassfish.internal.data.EngineRef.start(EngineRef.java:122)
          at org.glassfish.internal.data.ModuleInfo.start(ModuleInfo.java:273)
          at org.glassfish.internal.data.ApplicationInfo.start(ApplicationInfo.java:315)
          at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:498)
          at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:219)
          at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:491)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$2.execute(CommandRunnerImpl.java:539)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:548)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1425)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1500(CommandRunnerImpl.java:109)
          at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1760)
          at org.glassfish.deployment.autodeploy.AutoOperation.run(AutoOperation.java:164)
          at org.glassfish.deployment.autodeploy.AutoDeployer.deploy(AutoDeployer.java:595)
          at org.glassfish.deployment.autodeploy.AutoDeployer.deployAll(AutoDeployer.java:482)
          at org.glassfish.deployment.autodeploy.AutoDeployer.run(AutoDeployer.java:410)
          at org.glassfish.deployment.autodeploy.AutoDeployer.run(AutoDeployer.java:401)
          at org.glassfish.deployment.autodeploy.AutoDeployService$1.run(AutoDeployService.java:233)
          at java.util.TimerThread.mainLoop(Timer.java:555)
          at java.util.TimerThread.run(Timer.java:505)
      Caused by: java.lang.NullPointerException
          at org.glassfish.tyrus.server.TyrusServerConfiguration.<init>(TyrusServerConfiguration.java:72)
          at org.glassfish.tyrus.server.TyrusServerContainer.<init>(TyrusServerContainer.java:92)
          at org.glassfish.tyrus.server.ServerContainerFactory.create(ServerContainerFactory.java:118)
          at org.glassfish.tyrus.servlet.TyrusServletFilter.init(TyrusServletFilter.java:99)
          at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:275)
          at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:131)
          ... 28 more
      |#]
      

        Issue Links

          Activity

          Pavel Bucek added a comment -

          fixed in the trunk


            People

            • Assignee:
              Pavel Bucek
              Reporter:
              Pavel Bucek
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: