updatecenter
  1. updatecenter
  2. UPDATECENTER-132

BETA: GUI should filter out empty groups from installed modules

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      132

      Description

      1). launch GUI
      2). Install WSDP.
      3). Un-install WSDP.
      4). Now the GUI shows an empty group in the installed software.

      This must be fixed. Filtering is not done in the backend for efficiency. GUI
      should do the empty group filtering.

        Activity

        Nazrul added a comment -

        Fix by feb 05.

        raccah added a comment -
            • Issue 146 has been marked as a duplicate of this issue. ***
        raccah added a comment -
            • Issue 156 has been marked as a duplicate of this issue. ***
        Byron Nevins added a comment -

        I see WDP
        I see SWDP

        I do not see anything like WSDP

        sirajg added a comment -

        if no modules exist in module group do not show the module group in list

        sirajg added a comment -

        Here are the diffs :
        RCS file:
        /cvs/updatecenter/gui/src/java/com/sun/enterprise/update/ui/UpdateCenterTableModel.java,v
        retrieving revision 1.27
        diff -r1.27 UpdateCenterTableModel.java
        266d265
        < data.add(moduleGroup);
        268,270c267,268
        < // TODO - if modules is null shouldn't we
        < // skip showing the group?
        < if (modules != null){

        > if (modules != null && modules.length > 0){
        > data.add(moduleGroup);


          People

          • Assignee:
            sirajg
            Reporter:
            sv96363
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: