updatecenter
  1. updatecenter
  2. UPDATECENTER-144

BETA: Available Software - cancel button gets greyed out once clicked

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      144

      Description

      using Jan 22 workspace.

      Under "Available Software" tab, notice that once the "cancel" button is used
      once, it gets greyed out.

      To reproduce:
      1. Install Java EE 5 Tutorial
      2. click "cancel" button during installation
      3. now thry to install other software and notice that the "cancel" button is
      always greyed out.

        Activity

        Nazrul added a comment -

        Fix by feb 05.

        Nazrul added a comment -

        R -> B.

        raccah added a comment -

        Works for me - please try on a newer build.

        yifeng1 added a comment -

        on Jan 23 nightly, tried again and the same problem. Do you want to see my setup?

        raccah added a comment -

        It is now assigned to Byron. Please work with him directly if he cannot
        reproduce it.

        Byron Nevins added a comment -

        WTMM?

        R -> B

        Byron Nevins added a comment -

        This is easily reproduced....

        Byron Nevins added a comment -

        I am a newbie on this project. I have a fix. Should I just check it in or
        should it be reviewed? If so, somebody please review it.

        Index: src/java/com/sun/enterprise/update/ui/AbstractSoftwareTabPanel.java
        ===================================================================
        RCS file:
        /cvs/updatecenter/gui/src/java/com/sun/enterprise/update/ui/AbstractSoftwareTabPanel.java,v
        retrieving revision 1.18
        diff -u -r1.18 AbstractSoftwareTabPanel.java
        — src/java/com/sun/enterprise/update/ui/AbstractSoftwareTabPanel.java 26 Jan
        2007 21:53:41 -0000 1.18
        +++ src/java/com/sun/enterprise/update/ui/AbstractSoftwareTabPanel.java 27 Jan
        2007 06:38:07 -0000
        @@ -282,8 +282,10 @@
        if (!actionProgressBar.isVisible())

        { actionProgressBar.setVisible(true); }
        • if (!cancelButton.isVisible() && progress.isStopSupported())
          Unknown macro: {+ // WBN Issue 144+ if (progress.isStopSupported()) { cancelButton.setVisible(true); + cancelButton.setEnabled(true); } }
        Byron Nevins added a comment -

        Fixed as in the previous comment


          People

          • Assignee:
            Byron Nevins
            Reporter:
            yifeng1
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: