updatecenter
  1. updatecenter
  2. UPDATECENTER-165

GUI does not know what the backend is doing

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      165

      Description

      Try this:

      Be connected to Sun via VPN
      Do not configure the proxy server in 'Preferences'
      – this will make all downloads fail.

      In Available Software, select anything then press install

      'Details' says: Installed Successfully. That's a lie. It was definitely not
      installed successfully.

      the only indication of failure is the absence of the item in the 'Installed
      Software' tab.

      Meantime the huge exception trace went to the command window:
      com.sun.enterprise.update.download.DownloadFailureException:
      com.sun.enterprise.update.download.DownloadFailureException: java.net.U
      nknownHostException: java.net
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:165)
      at
      com.sun.enterprise.update.download.DefDownloader.run(DefDownloader.java:76)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: com.sun.enterprise.update.download.DownloadFailureException:
      java.net.UnknownHostException: java.net
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:185)
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:157)
      ... 4 more
      Caused by: java.net.UnknownHostException: java.net
      at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
      at java.net.Socket.connect(Socket.java:519)
      at java.net.Socket.connect(Socket.java:469)
      at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:382)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:494)
      at sun.net.www.http.HttpClient.<init>(HttpClient.java:231)
      at sun.net.www.http.HttpClient.New(HttpClient.java:304)
      at sun.net.www.http.HttpClient.New(HttpClient.java:316)
      at
      sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:817)
      at
      sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:769)
      at
      sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:694)
      at
      com.sun.enterprise.update.download.DefConnectionFactory.createConnection(DefConnectionFactory.java:192)
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:181)
      ... 5 more
      com.sun.enterprise.update.download.DownloadFailureException:
      com.sun.enterprise.update.download.DownloadFailureException: java.net.U
      nknownHostException: java.net
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:165)
      at
      com.sun.enterprise.update.download.DefDownloader.run(DefDownloader.java:76)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: com.sun.enterprise.update.download.DownloadFailureException:
      java.net.UnknownHostException: java.net
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:185)
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:157)
      ... 4 more
      Caused by: java.net.UnknownHostException: java.net
      at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
      at java.net.Socket.connect(Socket.java:519)
      at java.net.Socket.connect(Socket.java:469)
      at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:382)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:494)
      at sun.net.www.http.HttpClient.<init>(HttpClient.java:231)
      at sun.net.www.http.HttpClient.New(HttpClient.java:304)
      at sun.net.www.http.HttpClient.New(HttpClient.java:316)
      at
      sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:817)
      at
      sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:769)
      at
      sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:694)
      at
      com.sun.enterprise.update.download.DefConnectionFactory.createConnection(DefConnectionFactory.java:192)
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:181)
      ... 5 more
      com.sun.enterprise.update.download.DownloadFailureException:
      com.sun.enterprise.update.download.DownloadFailureException: java.net.U
      nknownHostException: java.net
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:165)
      at
      com.sun.enterprise.update.download.DefDownloader.run(DefDownloader.java:76)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: com.sun.enterprise.update.download.DownloadFailureException:
      java.net.UnknownHostException: java.net
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:185)
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:157)
      ... 4 more
      Caused by: java.net.UnknownHostException: java.net
      at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
      at java.net.Socket.connect(Socket.java:519)
      at java.net.Socket.connect(Socket.java:469)
      at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:382)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:494)
      at sun.net.www.http.HttpClient.<init>(HttpClient.java:231)
      at sun.net.www.http.HttpClient.New(HttpClient.java:304)
      at sun.net.www.http.HttpClient.New(HttpClient.java:316)
      at
      sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:817)
      at
      sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:769)
      at
      sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:694)
      at
      com.sun.enterprise.update.download.DefConnectionFactory.createConnection(DefConnectionFactory.java:192)
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:181)
      ... 5 more
      com.sun.enterprise.update.download.DownloadFailureException:
      com.sun.enterprise.update.download.DownloadFailureException: java.net.U
      nknownHostException: java.net
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:165)
      at
      com.sun.enterprise.update.download.DefDownloader.run(DefDownloader.java:76)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: com.sun.enterprise.update.download.DownloadFailureException:
      java.net.UnknownHostException: java.net
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:185)
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:157)
      ... 4 more
      Caused by: java.net.UnknownHostException: java.net
      at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
      at java.net.Socket.connect(Socket.java:519)
      at java.net.Socket.connect(Socket.java:469)
      at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:382)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:494)
      at sun.net.www.http.HttpClient.<init>(HttpClient.java:231)
      at sun.net.www.http.HttpClient.New(HttpClient.java:304)
      at sun.net.www.http.HttpClient.New(HttpClient.java:316)
      at
      sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:817)
      at
      sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:769)
      at
      sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:694)
      at
      com.sun.enterprise.update.download.DefConnectionFactory.createConnection(DefConnectionFactory.java:192)
      at
      com.sun.enterprise.update.download.DefDownloader.download(DefDownloader.java:181)
      ... 5 more

        Activity

        sv96363 added a comment -

        Looks like GUI bug to me. If the backend is thorwing exception- why is GUI is
        not show that and showing a success status

        Snjezana Sevo-Zenzerovic added a comment -

        This is another variant of issue #113.

        raccah added a comment -

        I agree - duplicate

            • This issue has been marked as a duplicate of 113 ***

          People

          • Assignee:
            raccah
            Reporter:
            Byron Nevins
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: