updatecenter
  1. updatecenter
  2. UPDATECENTER-207

BETA: Check for Updates: Get [Fatal Error] messages when click on Check for Updates button repeatedly and quickly

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: core
    • Labels:
      None
    • Environment:

      Operating System: Windows 2000
      Platform: PC

    • Issuezilla Id:
      207

      Description

      Build: java_ee_sdk-5_03-preview-bin-b08-windows-22_feb_2007.exe

      Received the following error messages on the console when click on Check for
      Updates button repeatedly and quickly. The error messages are different from
      trying the same reproducible steps twice:

      (Note: 1st time)
      C:\Sun\SDKjavaeeb8 withspace\updatecenter\bin>.\updatetool.bat ALL
      [Fatal Error] :1:5: XML document structures must start and end within the same e
      ntity.

      (Note: 2nd time)

      C:\Sun\SDKjavaeeb8 withspace\updatecenter\bin>.\updatetool.bat ALL
      [Fatal Error] :1:1: Premature end of file.

      Steps to reproduce:
      -------------------
      1) Install SDK build 8
      2) Invoke updatetool ALL
      3) Click 3 to 4 times quickly on the Check for Updates button
      4) Observe the error message on the console

        Activity

        nluu added a comment -

        Created an attachment (id=20)
        updatecenter.log file

        raccah added a comment -

        The new dialog is modal, so I don't think you can get into this situation
        anymore. But just in case, I disable the button and set a flag to omit a check
        if one's in progress already.
        Checking in UpdateCenterMainPanel.java;
        /cvs/updatecenter/gui/src/java/com/sun/enterprise/update/ui/UpdateCenterMainPanel.java,v
        <-- UpdateCenterMainPanel.java
        new revision: 1.34; previous revision: 1.33
        done

        nluu added a comment -

        I installed (03/27/07) UC build and still see the same problems:

        nluu@dhcp-usca14-133-134.sfbay.sun.com:/Users/nluu/workspace/UpdateCenter/publish/updatecenter/bin>
        ./updatetool ALL
        [Fatal Error] :1:2: XML document structures must start and end within the same
        entity.
        [Fatal Error] :-1:-1: Premature end of file.
        nluu@dhcp-usca14-133-134.sfbay.sun.com:/Users/nluu/workspace/UpdateCenter/publish/updatecenter/bin./updatetool

        [Fatal Error] :179:22: XML document structures must start and end within the
        same entity.
        [Fatal Error] :324:67: XML document structures must start and end within the
        same entity.

        raccah added a comment -

        schema2beans issue?

        Byron Nevins added a comment -
            • Issue 288 has been marked as a duplicate of this issue. ***
        Nazrul added a comment -

        Running into this issue very frequently. P3 -> P2.

        Nazrul added a comment -

        Ran into this issue very frequently. Once the update fails, there is no
        available software! The latest changes in the check for update status may be
        related. We need to fix this asap.

        rp100353 added a comment -

        During "Check for Updates" operation, UpdateCenterMainPanel was doing a refresh
        of the Available Software tab without waiting for the download of the catalog to
        be completed. UpdateCheckerDialog now does the refresh as a callback.

        Modified Files:
        /cvs/updatecenter/gui/src/java/com/sun/enterprise/update/ui/UpdateCenterMainPanel.java
        new revision: 1.39; previous revision: 1.38

        /cvs/updatecenter/gui/src/java/com/sun/enterprise/update/ui/UpdateCheckerDialog.java
        new revision: 1.4; previous revision: 1.3


          People

          • Assignee:
            rp100353
            Reporter:
            nluu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: