updatecenter
  1. updatecenter
  2. UPDATECENTER-221

Check for update: can't see the progress bar context, flash too quick

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: other
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      221

      Description

      build 33e , solaris sparc

      when user repeatly click the "Check for update" button, there will be a small
      progress bar showing, however it flashes so quick that user don't see any
      message, hence have no idea what is being updated.

      The progress bar should show status that catalog is being updated not something
      else to avoid user confusion.

        Activity

        sv96363 added a comment -

        Thats why I proposed showing "last update timestamp" for the user, so that user
        knows if update went through or not.

        Another approach- GUI can calculate how many available modules and updates were
        available before the Update and re-calculate the updates afterwards and display
        a message, if the update produced any differences or not. So that user does not
        have to dig through the module to figure out if there are new modules.

        Byron Nevins added a comment -

        Why not add a OK button to the dialog – but only when the user himself
        initiates the update check?

        raccah added a comment -

        Dialog requirements now specified in issue 252

            • This issue has been marked as a duplicate of 252 ***

          People

          • Assignee:
            raccah
            Reporter:
            yifeng1
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: