updatecenter
  1. updatecenter
  2. UPDATECENTER-228

Install or Uninstall selection also selects the description

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      228

      Description

      When you click install or uninstall button, GUI is also selecting(highlighting)
      the details description of the component. Not a conventional behavior.

        Activity

        Byron Nevins added a comment -

        added Kedar

        Byron Nevins added a comment -

        I've confirmed this bug on XP. Weird bug!

        Byron Nevins added a comment -

        ...

        Byron Nevins added a comment -

        I made the HTMl Display widget not accept focus. That did the job.

        Byron Nevins added a comment -

        This is probably what was happening:

        You press the install button
        the gui immediately make the button disabled.
        Since the active widget is now disabled – awt moves focus to the next item in
        the tab-order. This turns out to be the JEditorPane – which shows up
        highlighted when it has focus.

        O didn't test this theory – I simply made the window not accept focus which
        fixed the bug.

        There are 288 lines of diffs!!! I won't show it here. In reality, 1 line had a
        "real" change, which I'll show:

        > <Property name="focusable" type="boolean" value="false"/>


          People

          • Assignee:
            Byron Nevins
            Reporter:
            rp100353
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: