updatecenter
  1. updatecenter
  2. UPDATECENTER-290

Available Software: Description text is highlighted; unable to disable this feature

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: gui
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: Sun

    • Issuezilla Id:
      290

      Description

      Build: March 29, 2007 ~4PM
      OS: Solaris 10 Sparc (JDS)

      Available Software: (Details) Description texts are hightlighted if user clicks
      in the overview description area and the texts all subsequent selection of other
      components are also highlighted. Unable to disable this feature.

      Steps to reproduce:
      -------------------
      1) Invoke updatetool
      2) Click Check for Updates
      3) Click on the name of a component,i.e. Open ESB.
      4) Click the Overview text area of Open ESB.
      5) Click on the name of another component, i.e. Open ESB Blueprints.
      6) Observe that all the text in the Overview text area get highlighted.
      7) If click again in the Overview text area, then it will be un-highlighted;
      however, if the user click any other component, the text always get highlighted.

        Activity

        nluu added a comment -

        Created an attachment (id=33)
        Unable to disable highlighted text.

        Byron Nevins added a comment -

        I can't reproduce this. Maybe it only shows up on Solaris?

        Anyways, it was almost certainly caused by the 3 tabs being "focusable". I
        fixed that but I can't test it.

        Nolan can you build and verify that this bug is fixed?

        raccah added a comment -

        I could reproduce it before and can't now, so your change fixes it, but I don't
        think that's the right answer. If you setFocusable to false, then a user can't
        select and copy/paste text from there. And, I'm not sure if/how the links work.

        Byron Nevins added a comment -

        Fix #1 was making it non-focusable. Links work fine but as RR notes – the user
        can't select and copy text from the description.

        Fix #2 is an explicit setting of the selected text to nothing, which ought to
        wok but doesn't.

        I need to get the bug to appear on Windows before trying again.

        Any tips on how to reproduce the bug are appreciated...

        Byron Nevins added a comment -

        .

        Byron Nevins added a comment -

        I just can't ever get XP to display this bug.
        Reassigning to RR who can reproduce it at will...

        Nazrul added a comment -

        On 3/29 build, I don't see this issue on MacOS.

        Byron Nevins added a comment -

        Nazrul reported that the bug doesn't appear on Mac.
        So - it's on Solaris for sure.
        Linux: Unknown

        raccah added a comment -

        Nolan, now I can't reproduce on Solaris either. Can you try again?


          People

          • Assignee:
            raccah
            Reporter:
            nluu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: