updatecenter
  1. updatecenter
  2. UPDATECENTER-299

Available Software: Click on Install while one or more components are installing causes exception

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: installer
    • Labels:
      None
    • Environment:

      Operating System: Windows 2000
      Platform: All

    • Issuezilla Id:
      299

      Description

      Build: Glassfish V2 Build 41d
      OS: Windows

      Click on Install button while one or more components are installing causes
      exception on the console. The error message is below.

      Steps to reproduce:
      -------------------
      1) Install the Glassfish V2 Build 41d (nightly)
      2) From Available Software, select a few (large) component
      3) Click Install, accept the license, and while the components are installing,
      click Install again or select additional component and click Install. Note that
      the install button does not gray out.
      4) Observe the error message from the console where updatetool was launched:

      Exception in thread "AWT-EventQueue-0" java.lang.IllegalArgumentException
      at com.sun.enterprise.update.download.DownloadManagerImpl.download(Downl
      oadManagerImpl.java:58)
      at com.sun.enterprise.update.ui.DownloadInstallHelper.downloadAndInstall
      (DownloadInstallHelper.java:145)
      at com.sun.enterprise.update.ui.AbstractAvailableSoftwareTabPanel.doActi
      on(AbstractAvailableSoftwareTabPanel.java:71)
      at com.sun.enterprise.update.ui.AbstractSoftwareTabPanel.action(Abstract
      SoftwareTabPanel.java:285)
      at com.sun.enterprise.update.ui.AbstractSoftwareTabPanel.access$300(Abst
      ractSoftwareTabPanel.java:78)
      at com.sun.enterprise.update.ui.AbstractSoftwareTabPanel$4.actionPerform
      ed(AbstractSoftwareTabPanel.java:182)
      at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:18
      49)
      at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.jav
      a:2169)
      at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel
      .java:420)
      at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258
      )
      at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonL
      istener.java:236)
      at java.awt.Component.processMouseEvent(Component.java:5501)
      at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
      at java.awt.Component.processEvent(Component.java:5266)
      at java.awt.Container.processEvent(Container.java:1966)
      at java.awt.Component.dispatchEventImpl(Component.java:3968)
      at java.awt.Container.dispatchEventImpl(Container.java:2024)
      at java.awt.Component.dispatchEvent(Component.java:3803)
      at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212
      )
      at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3892)

      at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
      at java.awt.Container.dispatchEventImpl(Container.java:2010)
      at java.awt.Window.dispatchEventImpl(Window.java:1778)
      at java.awt.Component.dispatchEvent(Component.java:3803)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchTh
      read.java:242)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
      ad.java:163)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)

      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)

      at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

        Activity

        Snjezana Sevo-Zenzerovic added a comment -

        This is essentially duplicate of issue 293 and should already be fixed in trunk
        builds. Marking as such.

            • This issue has been marked as a duplicate of 293 ***

          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            nluu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: