updatecenter
  1. updatecenter
  2. UPDATECENTER-306

Select All to uninstall resulted in java.lang.ArrayIndexOutOfBoundsException

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: gui
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: Sun

    • Issuezilla Id:
      306

      Description

      Build: SDK 5.0_03 Build 14 / Glassfish Build 41d

      I saw this on the console screen while uninstalling the whole group on Solaris.
      (Go to Installed Software, click Select all checkbox to uninstall)

      /opt/SDK503b14appnluusol10> ./updatecenter/bin/updatetool
      Apr 26, 2007 6:38:16 PM com.sun.jbi.installer.JBIComponentsInstaller uninstall
      INFO: OpenESB JBI Components successfully uninstalled from
      /opt/SDK503b14appnluusol10/addons
      Exception in thread "AWT-EventQueue-0" java.lang.ArrayIndexOutOfBoundsException: 5
      at
      com.sun.enterprise.update.ui.UpdateCenterTableModel.getValueAt(UpdateCenterTableModel.java:184)
      at javax.swing.JTable.getValueAt(JTable.java:2638)
      at javax.swing.JTable.prepareRenderer(JTable.java:5652)
      at
      com.sun.enterprise.update.ui.AbstractSoftwareTabPanel$2.prepareRenderer(AbstractSoftwareTabPanel.java:127)
      at javax.swing.plaf.synth.SynthTableUI.paintCell(SynthTableUI.java:605)
      at javax.swing.plaf.synth.SynthTableUI.paintCells(SynthTableUI.java:502)
      at javax.swing.plaf.synth.SynthTableUI.paint(SynthTableUI.java:291)
      at javax.swing.plaf.synth.SynthTableUI.update(SynthTableUI.java:217)
      at javax.swing.JComponent.paintComponent(JComponent.java:758)
      at javax.swing.JComponent.paint(JComponent.java:1022)
      at javax.swing.JComponent.paintToOffscreen(JComponent.java:5104)
      at
      javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:285)
      at javax.swing.RepaintManager.paint(RepaintManager.java:1128)
      at javax.swing.JComponent._paintImmediately(JComponent.java:5052)
      at javax.swing.JComponent.paintImmediately(JComponent.java:4862)
      at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:723)
      at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:679)
      at javax.swing.RepaintManager.seqPaintDirtyRegions(RepaintManager.java:659)
      at
      javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:128)
      at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
      at
      java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
      at
      java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
      at
      java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

      Steps to reproduce:
      -------------------
      1) Install SDK 5.0_03 App Platform Build 14 on Solaris using default values
      http://javaweb.sfbay/java/re/javaeesdk/5.0_03/promoted/preview2/b14/bundles/
      2) Launch updatetool
      3) Select Installed Software
      4) Click Select All checkbox
      5) Click Uninstall
      6) Observe the exception on the console

        Activity

        raccah added a comment -

        I cannot reproduce this right now but I saw a similar problem in the past and
        had a fix in my workspace which I just checked in. Please reopen if it turns
        out to be a different problem.

        Byron Nevins added a comment -

        This could be a symptom of #309


          People

          • Assignee:
            raccah
            Reporter:
            nluu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: