updatecenter
  1. updatecenter
  2. UPDATECENTER-333

AS admin invocations of UC do not work properly

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: current
    • Fix Version/s: milestone 1
    • Component/s: core
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      333

      Description

      Apparently, UC client does not properly download catalogs when existing admin
      hooks (admin GUI, domain startup) trigger check for updates in spite. Relevant
      excerpt from Bugster Apparently, UC client does not properly download catalogs when existing admin
      hooks (admin GUI, domain startup) trigger check for updates in spite. Relevant
      excerpt from Bugster bug 6549934:

      Verified this on Aug 08 (b58a) nightly build of GlassFish on Mac OS X.

      When I start the domain or log on to admin console, the catalog is not
      downloaded.I am able to download the catalog (glassfish) when I launch the UC
      console.

      I tried setup.xml. Based on the opt out checkbox, the flag is set correctly in
      config.xml of UC. I see that <update-preference ... action-day="never" ..> becomes
      <update-preference ... action-day="tue"..> after running setup.xml.

      I see "LastUpdateCheckTime" in the config.xml. So, looks like the call from
      GlassFish to UC is happenning. We may have an issue in the UC backend code that
      is responsible for catalog download.:

      Verified this on Aug 08 (b58a) nightly build of GlassFish on Mac OS X.

      When I start the domain or log on to admin console, the catalog is not
      downloaded.I am able to download the catalog (glassfish) when I launch the UC
      console.

      I tried setup.xml. Based on the opt out checkbox, the flag is set correctly in
      config.xml of UC. I see that <update-preference ... action-day="never" ..> becomes
      <update-preference ... action-day="tue"..> after running setup.xml.

      I see "LastUpdateCheckTime" in the config.xml. So, looks like the call from
      GlassFish to UC is happenning. We may have an issue in the UC backend code that
      is responsible for catalog download.

        Activity

        Snjezana Sevo-Zenzerovic added a comment -
            • Issue 334 has been marked as a duplicate of this issue. ***
        rp100353 added a comment -

        This is a regression and was introduced when we added support for tokenized
        url's to support china downloads.

        rp100353 added a comment -

        File Modified:
        /cvs/updatecenter/core/src/java/com/sun/enterprise/update/download/DownloadManagerImpl.java
        new revision: 1.18; previous revision: 1.17


          People

          • Assignee:
            rp100353
            Reporter:
            Snjezana Sevo-Zenzerovic
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: