updatecenter2
  1. updatecenter2
  2. UPDATECENTER2-1260

[BLOCKING] MANIFEST file have issue in OSGi env.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: B27
    • Component/s: pkg-java
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      1,260
    • Tags:

      Description

      Admin console wants to update to later version, 2.1RR and found that there is
      issue with the MANIFEST files.

      It doesn't specify the dependency on javax.net classes.
      This needs to be fixed.
      Maybe look into using 'bnd' to generate the manifest file instead of doing that
      manually.

      Caused by: java.lang.NoClassDefFoundError: javax/net/ssl/HttpsURLConnection
      at com.sun.pkg.client.Image.getRepositoryURLConnection(Image.java:893)
      at com.sun.pkg.client.Catalog.refresh(Catalog.java:106)
      at com.sun.pkg.client.Image.refreshCatalogs(Image.java:1179)
      at
      org.glassfish.uc.admingui.UpdateCenterHandlers.refreshCatalog(UpdateCenterHandlers.java:539)

        Activity

        faouzia added a comment -

        I reproduced the issue by replacing the pkg-client.jar under glassfishv3/modules
        by the UC2.1 one.

        The following exception occures after some navigation in the different Tabs for
        packages management of the admin console :

        type Exception report

        message

        descriptionThe server encountered an internal error () that prevented it from
        fulfilling this request.

        exception

        javax.servlet.ServletException: java.lang.reflect.InvocationTargetException
        while attempting to process a 'beforeCreate' event for 'event208'.

        root cause

        java.lang.RuntimeException: java.lang.reflect.InvocationTargetException while
        attempting to process a 'beforeCreate' event for 'event208'.

        root cause

        java.lang.reflect.InvocationTargetException

        root cause

        java.lang.NoClassDefFoundError: javax/net/ssl/HttpsURLConnection

        root cause

        java.lang.ClassNotFoundException: javax.net.ssl.HttpsURLConnection

        note The full stack traces of the exception and its root causes are available in
        the GlassFish/v3 logs.

        Tom Mueller added a comment -

        This needs to be fixed for B26 so that we have a hope of having GFv3 pick up the
        2.2 version for their EA release.

        Also marking it for 2.1u1 if that release needs to be produced.

        rajkumarsrinivasan added a comment -

        Fixed in revision 1957 and 1958.

        Snjezana Sevo-Zenzerovic added a comment -

        Reopening the issue for tracking purposes until the fix is backported to 2.1 and
        updated jar file uploaded to Maven repository.

        Tom Mueller added a comment -

        Please do not reopen bugs for the purpose of tracking back porting to previous
        releases. That isn't how this project has agreed to track bugs.

        faouzia added a comment -

        This jar file prevents from loading the admin console.

        Anissa's investigation highlighted that the following Exception occured :

        SEVERE: Exception in thread "Thread-11"
        Apr 24, 2009 8:14:04 AM
        SEVERE: com.sun.enterprise.module.ResolveError: Not able to locate a unique
        module by name com.sun.pkg.client
        Apr 24, 2009 8:14:04 AM
        SEVERE: at
        com.sun.enterprise.v3.server.ClassLoaderHierarchyImpl.createApplicationParentCL(ClassLoaderHierarchyImpl.java:147)
        Apr 24, 2009 8:14:04 AM
        SEVERE: at
        org.glassfish.deployment.common.DeploymentContextImpl.createClassLoaders(DeploymentContextImpl.java:171)

        So, i look at the MANIFEST file, the bundle name is different from what we
        used to see. It says:

        Bundle-SymbolicName: pkg-client

        judytangs added a comment -

        I am marking this to P1 with [BLOCKING], we had talked about this bug in SDK
        pteam meeting today and feel this bug should give high priority since the last
        SDK build b04 is happen in two weeks.

        Here is SDK release schedule for JavaOne.

        4/30 - SDK b03
        5/7 - SDK b04
        5/15 - Go/NoGo
        5/27 - Release

        Tom Mueller added a comment -

        Now planned for B27 for the trunk. An update for 2.1 will be completed sooner.

        rajkumarsrinivasan added a comment -

        Fixed with revision 2012.


          People

          • Assignee:
            rajkumarsrinivasan
            Reporter:
            Anissa Lam
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: