updatecenter2
  1. updatecenter2
  2. UPDATECENTER2-1338

Solaris 10: Featured Software : Learn More button fails to start the browser

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: B26
    • Fix Version/s: B29
    • Component/s: updatetool
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: All

    • Issuezilla Id:
      1,338
    • Tags:

      Description

      open defaults.cfg file and changed the value of the attribute
      featured.feed.url to http://updates.sfbay.sun.com/atom/featuredfeed.xml

      1)Launch the updatetool and now we will find feature software view
      2)Now click any one to component and click Learn More button
      3)browser fails to popup

        Activity

        Hide
        arvindpachunoori added a comment -

        This issue is happening on Solaris10 U4

        Show
        arvindpachunoori added a comment - This issue is happening on Solaris10 U4
        Hide
        Joe Di Pol added a comment -

        This is likely an issue in WX with browser integration on older
        versions of gnome. At a minimum we need to investigate this and
        determine the scope of the problem and if there are any work
        arounds.

        Show
        Joe Di Pol added a comment - This is likely an issue in WX with browser integration on older versions of gnome. At a minimum we need to investigate this and determine the scope of the problem and if there are any work arounds.
        Hide
        Joe Di Pol added a comment -

        This, for the most part, works on the Solaris 10u4 system I tested on.
        I was running JDS R3 and when I click on the "Learn More" button or
        some other link in Update Tool it brings up Mozilla. I say "for the
        most part" because I have my preferred browser set to Firefox, but at
        least the link is displayed in a browser.

        On another S10u4 system with the CDE desktop it does not work at all
        which is not surprising.

        Arvind, where you using JDS (the gnome desktop)?

        In Preferences->Desktop Preferences->Preferred Applications what
        is your Web Browser setting?

        It would also be interesting to see if this is imporved in a later
        release of Solaris 10.

        Show
        Joe Di Pol added a comment - This, for the most part, works on the Solaris 10u4 system I tested on. I was running JDS R3 and when I click on the "Learn More" button or some other link in Update Tool it brings up Mozilla. I say "for the most part" because I have my preferred browser set to Firefox, but at least the link is displayed in a browser. On another S10u4 system with the CDE desktop it does not work at all which is not surprising. Arvind, where you using JDS (the gnome desktop)? In Preferences->Desktop Preferences->Preferred Applications what is your Web Browser setting? It would also be interesting to see if this is imporved in a later release of Solaris 10.
        Hide
        arvindpachunoori added a comment -

        Actually there is no default browser mentioned but in the custom browser I have
        given /usr/sfw/bin/mozilla
        But even though Iam able to see this error i.e
        ./updatetool
        execvp(mozilla, http://www.sun.com/software/products/appsrvr/index.xml) failed
        with error 2!
        execvp(mozilla, http://www.sun.com/software/products/appsrvr/index.xml) failed
        with error 2!

        Show
        arvindpachunoori added a comment - Actually there is no default browser mentioned but in the custom browser I have given /usr/sfw/bin/mozilla But even though Iam able to see this error i.e ./updatetool execvp(mozilla, http://www.sun.com/software/products/appsrvr/index.xml ) failed with error 2! execvp(mozilla, http://www.sun.com/software/products/appsrvr/index.xml ) failed with error 2!
        Hide
        Joe Di Pol added a comment -

        I'm not sure there is much we can do about this. In general the browser
        integration with the gnome version on Solaris 10u4 is flakey. I think
        the best we can do is document this in the release notes.

        Show
        Joe Di Pol added a comment - I'm not sure there is much we can do about this. In general the browser integration with the gnome version on Solaris 10u4 is flakey. I think the best we can do is document this in the release notes.
        Hide
        Mike Fitch added a comment -

        For Release Notes: genericize this issue to cover the fact that the Software
        Update UI has the same failing (browser doesn't launch on Solaris 10u4) in
        contexts where a browser would be started:

        1) Clicking an ad.
        2) Selecting an update to view the description - Click on a pkg link in the
        description.

        Show
        Mike Fitch added a comment - For Release Notes: genericize this issue to cover the fact that the Software Update UI has the same failing (browser doesn't launch on Solaris 10u4) in contexts where a browser would be started: 1) Clicking an ad. 2) Selecting an update to view the description - Click on a pkg link in the description.

          People

          • Assignee:
            Joe Di Pol
            Reporter:
            arvindpachunoori
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: