updatecenter2
  1. updatecenter2
  2. UPDATECENTER2-160

Release Notes: Document Linux 64 bit support

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0-MS06
    • Fix Version/s: 2.0-MS11
    • Component/s: doc
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      160

      Description

      Current UC2 requires 32 bit runtime compatibility libraries when running
      on 64 bit Linux systems. This should be documented in the Release Notes.
      Here are some specifics:

      Ubuntu 64 bit:

      You must install the 'ia32-libs' package

      Red Hat 64 bit

      Details are still TBD.

      And we have an issue with Ubuntu 8.04 (both 32 bit and 64 bit).
      See issue 159 for details.

        Activity

        Hide
        ckamps added a comment -

        Since issue 159 has been fixed and is being integrated into TP2, 159 does not
        have to be release noted.

        Show
        ckamps added a comment - Since issue 159 has been fixed and is being integrated into TP2, 159 does not have to be release noted.
        Hide
        Tom Mueller added a comment -

        This is needed for 2.0.

        Show
        Tom Mueller added a comment - This is needed for 2.0.
        Hide
        Tom Mueller added a comment -

        On Ubuntu 8.x (Hardy) 64-bit, the lib32nss-mdns package is also required.
        See issue 334 for details.

        Show
        Tom Mueller added a comment - On Ubuntu 8.x (Hardy) 64-bit, the lib32nss-mdns package is also required. See issue 334 for details.
        Hide
        Tom Mueller added a comment -
            • Issue 334 has been marked as a duplicate of this issue. ***
        Show
        Tom Mueller added a comment - Issue 334 has been marked as a duplicate of this issue. ***
        Hide
        nouar38 added a comment -

        RHEL 4.0 64 bits:

        • install the 32bit compatibility rpms compat-libstdc++, compat-libgcc,
          compat-gcc-32, compat-gcc-32-c++, compt-glibc

        RHEL 5.0 64 bits:

        • install the 32bit compatibility rpms compat-libstd++ and compat-libgcc
        • install the 32bit SDL-1.2 rpm (libSDL-1.2.so.0) to solve the import issue of
          wx module in updatetool GUI.
        Show
        nouar38 added a comment - RHEL 4.0 64 bits: install the 32bit compatibility rpms compat-libstdc++, compat-libgcc, compat-gcc-32, compat-gcc-32-c++, compt-glibc RHEL 5.0 64 bits: install the 32bit compatibility rpms compat-libstd++ and compat-libgcc install the 32bit SDL-1.2 rpm (libSDL-1.2.so.0) to solve the import issue of wx module in updatetool GUI.
        Hide
        Mike Fitch added a comment -

        Added the page
        http://wiki.updatecenter.java.net/Wiki.jsp?page=UC2Documentation.Platforms to
        the wiki to provide a place showing current platform support (and workarounds).

        On this page, provided info about packages and rpms needed for Linux 64-bit support.

        Changed the "Try" page to point to this "Platforms" page.

        Show
        Mike Fitch added a comment - Added the page http://wiki.updatecenter.java.net/Wiki.jsp?page=UC2Documentation.Platforms to the wiki to provide a place showing current platform support (and workarounds). On this page, provided info about packages and rpms needed for Linux 64-bit support. Changed the "Try" page to point to this "Platforms" page.

          People

          • Assignee:
            Mike Fitch
            Reporter:
            Joe Di Pol
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: