Issue Details (XML | Word | Printable)

Key: UPDATECENTER2-1618
Type: Bug Bug
Status: Resolved Resolved
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Alexis MP
Reporter: Alexis MP
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
updatecenter2

Unresponsive updatetool - UnsupportedRepositoryURI

Created: 16/Jul/09 07:27 AM   Updated: 24/Sep/09 08:50 AM   Resolved: 24/Sep/09 08:50 AM
Component/s: updatetool
Affects Version/s: 2.2
Fix Version/s: B38

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: All


Issuezilla Id: 1,618
Tags:
Participants: Alexis MP, mnsingh and Tom Mueller


 Description  « Hide

Using GlassFish v3 promoted b55 (uc2 version 2.2.0 build 30.21.64), I add a local repository which I make the preferred and disable the existing two others.
Installing a first package from the local repository works fine. Trying to install the second repository (which happens to have a required dependency on the first one triggers the following error :

Timestamp : [2009-07-16 15:58:20 CEST(+0200)]
wx Version : [2.8.8.0]
wx Platform : [__WXGTK__]
Python Version: [UNKNOWN]
Platform : [UNKNOWN]

Traceback (innermost last):
File "/export/home/alexismp/glassfishv3b55/updatetool/vendor-packages/updatetool/gui/appinfonotebook.py", line 514, in OnNotebookPageChanged
img.load_config()
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/image.py", line 268, in load_config
ic.read(self.imgdir)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/imageconfig.py", line 146, in read
k, a = self.read_publisher(cp, s)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/imageconfig.py", line 441, in read_publisher
r.add_origin(origin, ssl_cert=ssl_cert, ssl_key=ssl_key)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 450, in add_origin
priority=priority, ssl_cert=ssl_cert, ssl_key=ssl_key)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 317, in __add_uri
trailing_slash=trailing_slash)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 102, in _init_
self.uri = uri
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 172, in __set_uri
raise api_errors.UnsupportedRepositoryURI(uri)
UnsupportedRepositoryURI: The URI 'null' contains an unsupported scheme ''.

2009-07-16 15:58:21 ERROR Application ID: [Update Tool 2.2.0 (Build 30.2164)]
Timestamp : [2009-07-16 15:58:21 CEST(+0200)]
wx Version : [2.8.8.0]
wx Platform : [__WXGTK__]
Python Version: [UNKNOWN]
Platform : [UNKNOWN]

Traceback (innermost last):
File "/export/home/alexismp/glassfishv3b55/updatetool/vendor-packages/updatetool/gui/appinfonotebook.py", line 514, in OnNotebookPageChanged
img.load_config()
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/image.py", line 268, in load_config
ic.read(self.imgdir)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/imageconfig.py", line 146, in read
k, a = self.read_publisher(cp, s)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/imageconfig.py", line 441, in read_publisher
r.add_origin(origin, ssl_cert=ssl_cert, ssl_key=ssl_key)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 450, in add_origin
priority=priority, ssl_cert=ssl_cert, ssl_key=ssl_key)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 317, in __add_uri
trailing_slash=trailing_slash)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 102, in _init_
self.uri = uri
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 172, in __set_uri
raise api_errors.UnsupportedRepositoryURI(uri)
UnsupportedRepositoryURI: The URI 'null' contains an unsupported scheme ''.

2009-07-16 15:58:21 ERROR Application ID: [Update Tool 2.2.0 (Build 30.2164)]
Timestamp : [2009-07-16 15:58:21 CEST(+0200)]
wx Version : [2.8.8.0]
wx Platform : [__WXGTK__]
Python Version: [UNKNOWN]
Platform : [UNKNOWN]

Traceback (innermost last):
File "/export/home/alexismp/glassfishv3b55/updatetool/vendor-packages/updatetool/gui/appinfonotebook.py", line 514, in OnNotebookPageChanged
img.load_config()
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/image.py", line 268, in load_config
ic.read(self.imgdir)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/imageconfig.py", line 146, in read
k, a = self.read_publisher(cp, s)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/imageconfig.py", line 441, in read_publisher
r.add_origin(origin, ssl_cert=ssl_cert, ssl_key=ssl_key)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 450, in add_origin
priority=priority, ssl_cert=ssl_cert, ssl_key=ssl_key)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 317, in __add_uri
trailing_slash=trailing_slash)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 102, in _init_
self.uri = uri
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 172, in __set_uri
raise api_errors.UnsupportedRepositoryURI(uri)
UnsupportedRepositoryURI: The URI 'null' contains an unsupported scheme ''.

2009-07-16 15:58:21 ERROR Application ID: [Update Tool 2.2.0 (Build 30.2164)]
Timestamp : [2009-07-16 15:58:21 CEST(+0200)]
wx Version : [2.8.8.0]
wx Platform : [__WXGTK__]
Python Version: [UNKNOWN]
Platform : [UNKNOWN]

Traceback (innermost last):
File "/export/home/alexismp/glassfishv3b55/updatetool/vendor-packages/updatetool/gui/appinfonotebook.py", line 514, in OnNotebookPageChanged
img.load_config()
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/image.py", line 268, in load_config
ic.read(self.imgdir)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/imageconfig.py", line 146, in read
k, a = self.read_publisher(cp, s)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/imageconfig.py", line 441, in read_publisher
r.add_origin(origin, ssl_cert=ssl_cert, ssl_key=ssl_key)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 450, in add_origin
priority=priority, ssl_cert=ssl_cert, ssl_key=ssl_key)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 317, in __add_uri
trailing_slash=trailing_slash)
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 102, in _init_
self.uri = uri
File "/export/home/alexismp/glassfishv3b55/pkg/vendor-packages/pkg/client/publisher.py", line 172, in __set_uri
raise api_errors.UnsupportedRepositoryURI(uri)
UnsupportedRepositoryURI: The URI 'null' contains an unsupported scheme ''.

The image then becomes unusable and any "pkg" command results in the above "UnsupportedRepositoryURI" error.

It seems to me that disabling the repository the GlassFish packages came from (dev.glassfish.org) is what triggers the issue (doing the same as above but without disabling
that publisher works ok). Not sure why the initial package installs without a hitch though...



mnsingh added a comment - 13/Aug/09 08:31 AM

Java API saw this. TODO : Get more info from Tom. Published in the installed pkg
not in the cfg_cache cause this.


Tom Mueller added a comment - 13/Aug/09 11:10 AM

This might be related to issue 1612.

In that issue, if a publisher name is used to pre-install a package into an
install bundle, an then that bundle is shipped without that publisher name being
defined in the cfg_cache file, and then the Java bootstrap is used on the image,
the cfg_cache file will end up with [authority_xxxx] entries in the cfg_cache
file that have "origin = null". This then causes the stack trace that is in the
description.

So if someone could look at the bundle and see if this situation exists, and if
the submitter could indicate whether the Java bootstrap was used on the image,
then one could confirm if this is indeed the same as issue 1612.


Tom Mueller added a comment - 13/Aug/09 11:12 AM

To work-around this problem, manually edit the .org.opensolaris,pkg/cfg_cache
file to remove all [authority_xxxx] entries that have "origin = null". This also
enables one to see the names of the publishers that were used to install
packages. After performing the edit, do "bin/pkg list". If any of the packages
have a publisher name in () after the name of the package, and those names are
not in the output generated by "bin/pkg publisher", then we have the situation
that is triggered in 1612.


mnsingh added a comment - 17/Sep/09 03:03 PM

I am unable to reproduce this issue. If somebody has a repo or a way to repdoce
this, please let me know.

Here are the steps I followed.

1) Download and extract

http://download.java.net/glassfish/v3-preview/release/glassfish-v3-preview.zip

2) cd glassfishv3

3) ./bin/updatetool

This pulls and installs the updatetool

4) ./bin/updatetool &

5) run a local repo and pull ant, felix and ant-doc into it.

a) cd /tmp ; mkdir localrepo ; pkg.depotd -d localrepo -p 10000 &

b) pkgrecv -s 'http://pkg.sun.com/layered-collection/dev' \
-d 'http://localhost:10000' ant ant-doc felix

6) In the updatetool from step 4

a) Add http://localhost:10000 as preferred
b) disable the other two repos
c) install ant
d) install ant-doc

All during this I keep checking the cfg_cache file for any null origin repos
getting included but no such repo gets added.

I intend to close this if I can not reproduce this. Meanwhile I'll add some
exception handler code around where this is occuring just to be safe.


mnsingh added a comment - 17/Sep/09 03:26 PM

In newer builds, the exceptions in appinfonotebook.py are already trapped
silently so even if this happens, the tool won't freeze.

Unless some sort of backport for GFv3 is required or a way to reproduce this is
shown, I'll be closing this issue.

Reassigning this back to the submitter to ask for comments.


mnsingh added a comment - 24/Sep/09 08:50 AM

Closing because haven't heard from the submitter on it after my recent inability
to reproduce the issue.