updatecenter2
  1. updatecenter2
  2. UPDATECENTER2-1699

PermissionException during mq-gf-config package update on Windows

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.2-build-unknown
    • Component/s: updatetool
    • Labels:
      None
    • Environment:

      Operating System: Windows (generic)
      Platform: Other

    • Issuezilla Id:
      1,699
    • Status Whiteboard:

      2.1u1 candidate

      Show
      2.1u1 candidate
    1. error.JPG
      174 kB
    2. mqerror.JPG
      170 kB

      Activity

      lalithasaroja added a comment -

      I tried the same scenario while doing GFV3 testing with UC2.2U2 & UC 2.3 Build
      34 on Windows XP. I downloaded the Glassfish V3 preview zip file (which contains
      UC 2.1) from https://glassfish.dev.java.net/downloads/v3-preview.html . I edited
      and changed the preferred repo to http://pkg.glassfish.org/v3/dev/. I saw
      updates for GF in Available Updates view. I tried to apply all the updates then
      I saw the error

      I did not see any traceback error but an error was displayed with Insufficient
      Permissions. I will attach the snapshot.

      lalithasaroja added a comment -

      Created an attachment (id=588)
      error displayed when trying to install all the updates

      lalithasaroja added a comment -

      Created an attachment (id=589)
      error displayed when trying to update only mq components

      Snjezana Sevo-Zenzerovic added a comment -

      Relevant info from e-mail thread:

      The starting point of this upgrade is MQ version 4.4-6.3, which would be this one:

      http://pkg.glassfish.org/v3/dev/windows/manifest/0/mq-config-gf%404.4%2C0-6.3%3A20090422T172120Z

      So, all permissions in the old one are in fact 0644, although it is interesting
      to note that quite a few files got removed from the package...

      BTW, Lalitha's problem is not identical to this one, it is actually the one we
      hit last week, i.e. UC issue 1686. We applied workaround for that one since we
      published Windows version of MQ packages with more liberal permissions, but in
      the case of config package permissions are already set to more than read-only...

      Tom Mueller added a comment -

      The root cause of this problem is that in version 2.1 of the UC2 toolkit, pkg(5)
      leaves a file descriptor open during the upgrade step when the preserve
      attribute is used on a file and that file already exists in the image.

      This problem was fixed in the pkg(5) code by changeset 873:b95d76c53b5e on Feb
      13, 2009. That change to pkg(5) was picked up by the UC2 toolkit in the 2.2
      release. So this problem doesn't exist anymore in 2.2 and later.

      However, even if the 2.2 versions of the UC2 packages are in the GFv3
      repository, the update to the mq-gf-config file would still fail if the update
      is applied all in one step, because the update would be done with the old code.
      To make the package with the preserve tag work would require updating the pkg
      package first, followed by the mq-gf-config package.

      Another option is to remove the preserve tag from the action.

      Backporting the change to a 2.1 update would not be effective unless there was a
      willingness to deploy that update to the GFv3 Preview repositories first, given
      people a chance to apply that update, and then deploy the update to the
      mq-gf-config package. The same thing could be done with the 2.2 packages.

      Marking this as resolved and fixed in 2.2 (build unknown) as this problem is
      fixed on the trunk. Adding the 2.1u1 candidate whiteboard value to indicate
      that this might be a candidate for fixing in a 2.1 update.


        People

        • Assignee:
          Tom Mueller
          Reporter:
          Snjezana Sevo-Zenzerovic
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: