updatecenter2
  1. updatecenter2
  2. UPDATECENTER2-1802

--notifier popup on Linux does not follow the shells locale

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: B37
    • Fix Version/s: not determined
    • Component/s: l10n
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      1,802

      Description

      LINUX 5.3

      --swupdate popup on Linux does not follow the shells locale.

      Steps:
      1.Log in to Linux in a Spanish environment
      2.Lunch a shell and set it to French
      3.--swupdate popup
      4.The popup appears in Spanish and not in French, but UC comes up in French

        Activity

        pierrot added a comment -

        Created an attachment (id=618)
        See the popup dialog (Spanish) and the UC UI (French)

        Chris Kasso added a comment -

        On Ubuntu 10.08 and Solaris I tried to reproduce this with no luck.

        I logged in using es_ES.UTF-8.
        I launched updatetool --swupdate and confirmed it was running in the Spanish
        locale. I quit the tool.
        I changed the shell's locale via: % export LC_ALL=fr_FR.UTF-8
        I launched updatetool --swupdate and confirmed it was running in the French locale.

        mnsingh added a comment -

        The notifier must have been launched when the user logged in to the spanish
        environment as stated. swupdate was launched by hand in french locale.

        pierrot added a comment -

        Hi Kasso, Mnsingh.

        Let me reopen this issue because:

        • maybe it is RH 5.3 only related
        • this bug is only about the little popup box that comes up when launching the
          updatetool --swupdate. The UI itself follows correctly the shells locale. Please
          see the attache screenshot.

        Consider this and then please reset the bug as WORKFORME if needed. Thanks !

        Chris Kasso added a comment -

        In the screenshot you provided the popup is obscured by other windows. Can you
        tell us what the popup says or provide another screenshot where the popup is in
        the front?

        pierrot added a comment -

        Hi. You're right, I did not pay attention to that. Actually you can still see a
        bit of the popup, where it is written "El sistema no está".

        One more thing: I think this popup is actually not related to "updatetool
        --swupdate" but more to "updatetool --notifier". I was testing both commands,
        and I think it was just a conincidence that the popup appeared just when I was
        executing "updatetool --swupdate".

        Therefore changing subject.

        I tried to reproduce it again with "updatetool --notifier" but somehow the popup
        is bot coming out. Can you please try with "updatetool --notifier" ?

        Chris Kasso added a comment -

        The notifier can be started in several ways:

        1) At login (inherits login locale)
        2) By updatetool (it is started in the background a few minutes after updatetool
        is launched) (inherits updatetool's locale)
        3) Manually via updatetool --notifier (inherits the shell's locale)

        Given the notifier is presenting its dialog in Spanish - the locale used at
        login, the message balloon is probably coming from the notifier process started
        when the user logged into the system.

        You can use updatetool -n --shutdown to stop all running instances of the
        notifier.

        If you believe this is not correct please reopen the bug and provide
        step-by-step instructions detailing how to reproduce the issue.

        pierrot added a comment -

        Thanks for those details. I'll try them and verify the behavior is correct. Will
        reopen the bug if needed. Thanks again !


          People

          • Assignee:
            Chris Kasso
            Reporter:
            pierrot
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: