updatecenter2
  1. updatecenter2
  2. UPDATECENTER2-2036

UC 2.4 pkg-toolkit-incorporation has bad python2.4 dependency

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: B45
    • Fix Version/s: B45
    • Component/s: build
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      2,036

      Description

      The pkg-toolkit-incorporation package for UC 2.4 has a dependency on:

      pkg:/python2.4-minimal@2.4-45

      This is incorrect. If we need such a dependency it should be:

      pkg:/python2.4-minimal@2.4.4.0-45
      pkg:/python2.4-minimal@2.4.5.0-45 For the Mac

      The current definition causes a constraint violation when performing a UC 2.3 to
      UC 2.4 upgrade since the new incorporation specifies a lower version for
      python2.4 than the UC 2.3 incorporation:

      PlanCreationException: The following package(s) violated constraints:
      "Package pkg-toolkit-incorporation contains constraint that requires
      downgrade of installed pkg
      pkg:/python2.4-minimal@2.4.4.0,0-38.2679:20100112T215610Z:
      Pkg python2.4-minimal: Optional min_version: 2.4,5.11-45 max
      version: 2.4,5.11-45 defined by: pkg:/pkg-toolkit-incorporation

        Activity

        Hide
        Joe Di Pol added a comment -

        On the other hand I think we should not ship a python2.4 package at all in UC
        2.4. See UPDATECENTER2-2035

        Show
        Joe Di Pol added a comment - On the other hand I think we should not ship a python2.4 package at all in UC 2.4. See UPDATECENTER2-2035
        Hide
        Tom Mueller added a comment -

        I suspect that what is happening here is that we are seeing a bug in the
        constraint evaluation code in 2.3 which is actually fixed by the SAT solver in
        2.4. Unfortunately, we have to depend on the 2.3 code to do the upgrade to 2.4,
        so we have to work-around that bug.

        We have to do something in 2.4 that will either replace or remove the
        python2.4-minimal package. With the 2.4 update code, an obsolete will remove
        it. It might also be possible to do a rename to replace it. We need to look at
        what is possible with the 2.3 update logic.

        Show
        Tom Mueller added a comment - I suspect that what is happening here is that we are seeing a bug in the constraint evaluation code in 2.3 which is actually fixed by the SAT solver in 2.4. Unfortunately, we have to depend on the 2.3 code to do the upgrade to 2.4, so we have to work-around that bug. We have to do something in 2.4 that will either replace or remove the python2.4-minimal package. With the 2.4 update code, an obsolete will remove it. It might also be possible to do a rename to replace it. We need to look at what is possible with the 2.3 update logic.
        Hide
        Joe Di Pol added a comment -

        Is there a compelling reason why we must remove the python2.4 package?

        As described in UPDATECENTER2-2035 I don't think we can remove the python2.4-minimal
        package when a person upgrades from UC 2.3 to UC 2.4. That's because it's the UC
        2.3 code (python2.4) that is running when the upgrade occurs, and we can't
        remove that runtime while it is running otherwise you get errors like that in
        UPDATECENTER2-2035.

        My opinion is we just leave well enough alone. The python2.6 package really is
        not obsoleting the python2.4 package since it does not provide the same
        interfaces as the python2.4 package (it is installed in a different location).
        UC 2.4 should just walk away from the python2.4 package. If after an upgrade a
        user wants to remove the package they can do so easily.

        Show
        Joe Di Pol added a comment - Is there a compelling reason why we must remove the python2.4 package? As described in UPDATECENTER2-2035 I don't think we can remove the python2.4-minimal package when a person upgrades from UC 2.3 to UC 2.4. That's because it's the UC 2.3 code (python2.4) that is running when the upgrade occurs, and we can't remove that runtime while it is running otherwise you get errors like that in UPDATECENTER2-2035 . My opinion is we just leave well enough alone. The python2.6 package really is not obsoleting the python2.4 package since it does not provide the same interfaces as the python2.4 package (it is installed in a different location). UC 2.4 should just walk away from the python2.4 package. If after an upgrade a user wants to remove the package they can do so easily.
        Hide
        Tom Mueller added a comment -

        The reasons for removing python2.4-minimal are:

        • conserve space
        • clean up the ugliness of having an unused package and unused files in the image

        But you make a compelling argument that we might be better served just walking
        away from it.

        One possible compromise is that we leave all of the files in it, but make it
        obsolete. The 2.3 software doesn't recognize the pkg.obsolete flag, so it won't
        be removed. The manifest will just be updated with the new setting. When the
        2.4 software eventually does an image update, then the package will be removed
        when it is no longer being used.

        Show
        Tom Mueller added a comment - The reasons for removing python2.4-minimal are: conserve space clean up the ugliness of having an unused package and unused files in the image But you make a compelling argument that we might be better served just walking away from it. One possible compromise is that we leave all of the files in it, but make it obsolete. The 2.3 software doesn't recognize the pkg.obsolete flag, so it won't be removed. The manifest will just be updated with the new setting. When the 2.4 software eventually does an image update, then the package will be removed when it is no longer being used.
        Hide
        Joe Di Pol added a comment -

        Fixed in r2689.

        The python2.4-minimal package has been removed from the incorporation (it has
        also been removed from the UC 2.4 build – see UPDATECENTER2-2035).

        Show
        Joe Di Pol added a comment - Fixed in r2689. The python2.4-minimal package has been removed from the incorporation (it has also been removed from the UC 2.4 build – see UPDATECENTER2-2035 ).

          People

          • Assignee:
            Joe Di Pol
            Reporter:
            Joe Di Pol
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: