updatecenter2
  1. updatecenter2
  2. UPDATECENTER2-2044

Faced a case where the notifier does not report an update for a user image while updatetool does

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: B38a
    • Fix Version/s: not determined
    • Component/s: notifier
    • Labels:
      None
    • Environment:

      Operating System: Windows Vista
      Platform: Sun

    • Issuezilla Id:
      2,044

      Description

      I wanted to check the issue 1970

      I had multiple user images (4) having a local repo

      2 user images with a remote repo :

      1 is user image from GFV3 bundled with NetBeans6.8 for which I have installed 2
      old versions of 2 packages

      1 user image with http://updates.sfbay.sun.com/dev/promoted in which I
      installed older versions of Open MQ and Java DB

      I checked in updatetool that updates are shown for both user images

      I logout/login from the machine (which stopped the repo used for the other user
      images)

      After a while, The notifier balloon was displayed , but It shows there is are
      available updates only for the user image with
      http://updates.sfbay.sun.com/dev/promoted/ repositroy but does not highlight
      available updates for GFV3 user image.

      I launched updatetool once again and checked that updatetool still displays
      updates for both user images.

      In the notifier logfile, I found the following Warninig:
      2010-01-14 11:38:07 WARNING 0: Problem checking for updates in ``Sun GlassFish
      Enterprise Server v3'':
      Components list could not be refreshed successfully due to a network issue with
      the following publishers:

      dev.glassfish.sun.com
      contrib.glassfish.org
      contrib.glassfish.sun.com
      dev.glassfish.org
      release.glassfish.sun.com

      The error was:

      Could not retrieve catalog from 'dev.glassfish.sun.com'
      Exception: str:[Errno 17] File exists repr:<exceptions.OSError instance at
      0x045218F0>
      Could not retrieve catalog from 'contrib.glassfish.org'
      Exception: str:[Errno 17] File exists repr:<exceptions.OSError instance at
      0x0451BA30>
      Could not retrieve catalog from 'contrib.glassfish.sun.com'
      Exception: str:[Errno 17] File exists repr:<exceptions.OSError instance at
      0x046A7FD0>
      Could not retrieve catalog from 'dev.glassfish.org'
      Exception: str:[Errno 17] File exists repr:<exceptions.OSError instance at
      0x04654918>
      Could not retrieve catalog from 'release.glassfish.sun.com'
      Exception: str:[Errno 17] File exists repr:<exceptions.OSError instance at
      0x046549B8>

      The available components list may not be accurate or complete.

      But I am wondering why updatetool is able to find updates for this user image
      and not the notifier and SW Update Manager

        Activity

        faouzia added a comment -

        Created an attachment (id=680)
        notifier logfile with Debug level when this problem happened

        faouzia added a comment -

        An other strange thing :
        the notifier highlighted there is one user image having update

        I then launched the SW Update Manager and noticed it provides the same picture

        Then, I clicked on Refresh button from the SWUM, and then It shows there is an
        other user image having updates. But this second user image is not the GFV3
        user image but one of the user images having a repo which down and a second rep
        o up and running.

        For this user image, updatetool is not able to show there are available
        updates, it shows an Error message when I selected Available pdates view
        stating that the repository can not be contacted because of a Network problem

        So, the conclusion is that there is inconsistency between notifier, SWUM and
        updatetool in updates availability conditions

        faouzia added a comment -

        The problem only happens after login

        When This problem happened, I Opened the Preferences, Unselected "Automatic
        Check For Updates" then selected it one again to restart the notifier. And
        after this operation, the notifier balloon reports there are updates available
        for 2 User Images including GFV3 User Image.

        Then I retried once again logout/login, and Faced the same problem descibed in
        the issue.

        Chris Kasso added a comment -

        The error message, the info in the logs and the behavior described suggests this
        is an intermittent networking issue.

        You might try running the notifier on the command line with checks every 45
        seconds to see if the problem comes and goes:

        updatetool -n --debug --interval=45

        faouzia added a comment -

        I tried to run the notifier using --interval 45 manually,

        The notifier reported more than 10 consecutive times that there is an update for
        the GFV3 user image without any problem.

        Then I logout/login, and once again the problem occurred : The notifier does not
        report the available update for the GFV3 user image.

        So, the Network probel only occures at login time.

        I will need to check with Lalitha and Arvind if they can try on an other Vista
        machine, as I don's have an other machine in Grenoble.

        ckamps added a comment -

        Removing 2.3u1 keyword from this issue until its shown to be a stopper issue for
        2.3u1.

        Chris Kasso added a comment -

        I'm unable to reproduce this issue. If you can reproduce it on other systems
        please reopen the issue.


          People

          • Assignee:
            Chris Kasso
            Reporter:
            faouzia
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: