Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: B45
    • Fix Version/s: B146
    • Component/s: notifier
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      2,065
    • Tags:

      Description

      The implementation introduced as part of issue 1297 is not working properly in
      the following scenarios:

      1) notifier is running with the SW Update UI displayed (from image A)
      2) updatetool (running from image B) applies an updatetool update to image A.
      3) notifier should prompt user for restart because the SW Update UI is open and
      the update is applicable to the notifier.

      1) notifier is running with the SW Update UI displayed (from image A)
      2) updatetool (also running from image A) applies an updatetool update to image A
      3) updatetool prompts user for restart. User choose to restart.
      4) notifier should prompt user for restart because SW Update UI is open.

      Root cause: In the first scenario updatetool is only sending the notifier an
      UPDATE_CHECK IPC message. It should also send the RESTART_CHECK message. In
      the second scenario updatetool is sending the notifier a RESTART IPC message
      instead of the RESTART_CHECK message. The RESTART message causes the notifier
      to blindly restart without prompting the user.

        Activity

        Chris Kasso added a comment -

        r2712
        src/gui/mainframe.py

        Chris Kasso added a comment -

        Backported r2712 as r2758:

        updatetool/src/notifier/application.py
        updatetool/src/gui/mainframe.py
        updatetool/src/common/ips/apptask.py

          People

          • Assignee:
            Chris Kasso
            Reporter:
            Chris Kasso
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: