updatecenter2
  1. updatecenter2
  2. UPDATECENTER2-2143

Confusing messages displayed after upgrading in CLI from 2.3 to 2.3u2

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.3Update1
    • Fix Version/s: not determined
    • Component/s: ipsenhancement
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: Sun/x86

    • Issuezilla Id:
      2,143
    • Tags:

      Description

      I noticed this behavior on Windows 2008R2 and Windows XP as well. Here I am
      trying to upgrade from 2.3 to 2.3u2 in CLI

      I downloaded 2.3.0RR toolkit and installed updatetool using a local repo
      pointing to 2.3.0RR (platform specific repo). The installation was successful.
      Since the updates.sfbay is down, I started a repo pointing to B38b and changed
      the url pointing to B38b repo

      I upgraded the 2.3 image using image-update and the update was successful but in
      the end there was a confusing message to the user.

      Confusing Message :

      'MY_HOME*' is not recognized as an internal or external command,
      operable program or batch file.
      'C:\Users\Administrator\Downloads\pkg-toolkit-2.3.0\pkg-toolkit\bin\' is not rec
      ognized as an internal or external command,
      operable program or batch file.
      No updates available for this image.

      C:\Users\Administrator\Downloads\pkg-toolkit-2.3.0\pkg-toolkit\bin>pkg.bat image
      -update
      No updates available for this image.

      C:\Users\Administrator\Downloads\pkg-toolkit-2.3.0\pkg-toolkit\bin>pkg.bat refre
      sh --full

      C:\Users\Administrator\Downloads\pkg-toolkit-2.3.0\pkg-toolkit\bin>pkg.bat list
      -v
      FMRI STATE UFIX

      pkg:/pkg@1.122.2,0-38.2493:20091008T194957Z installed u---

      pkg:/pkg-extra-tools@0.2.0,0-38.2493:20091008T194915Z installed u---

      pkg:/pkg-java@1.122,0-38.2493:20091008T194916Z installed u---

      pkg:/pkg-toolkit@2.3.0,0-38.2493:20091008T194956Z installed u---

      pkg:/pkg-toolkit-incorporation@2.3.0,0-38.2493:20091008T194956Z installed u---

      pkg:/python2.4-minimal@2.4.4.0,0-38.2493:20091008T195019Z installed u---

      pkg:/updatetool@2.3.0,0-38.2493:20091008T195031Z installed u---

      pkg:/wxpython2.8-minimal@2.8.10.1,0-38.2493:20091008T195050Z installed u---

      C:\Users\Administrator\Downloads\pkg-toolkit-2.3.0\pkg-toolkit\bin>pkg.bat image
      -update
      DOWNLOAD PKGS FILES XFER (MB)
      Completed 8/8 407/407 3.2/3.2

      PHASE ACTIONS
      Removal Phase 10/10
      Install Phase 17/17
      Update Phase 651/651
      'MY_HOME*' is not recognized as an internal or external command,
      operable program or batch file.
      'C:\Users\Administrator\Downloads\pkg-toolkit-2.3.0\pkg-toolkit\bin\' is not rec
      ognized as an internal or external command,
      operable program or batch file.
      No updates available for this image.

      C:\Users\Administrator\Downloads\pkg-toolkit-2.3.0\pkg-toolkit\bin>pkg.bat list
      -v
      FMRI STATE UFIX

      pkg:/pkg@1.122.2,0-38.2770:20100414T215305Z installed ----

      pkg:/pkg-extra-tools@0.2.0,0-38.2770:20100414T215223Z installed ----

      pkg:/pkg-java@1.122,0-38.2770:20100414T215224Z installed ----

      pkg:/pkg-toolkit@2.3.2,0-38.2770:20100414T215305Z installed ----

      pkg:/pkg-toolkit-incorporation@2.3.2,0-38.2770:20100414T215225Z installed ----

      pkg:/python2.4-minimal@2.4.6.0,0-38.2770:20100414T215324Z installed ----

      pkg:/updatetool@2.3.2,0-38.2770:20100414T215335Z installed ----

      pkg:/wxpython2.8-minimal@2.8.10.1,0-38.2770:20100414T215353Z installed ----

      C:\Users\Administrator\Downloads\pkg-toolkit-2.3.0\pkg-toolkit\bin>

        Activity

        Joe Di Pol added a comment -

        This is likely because pkg.bat is being modified while it is running. We already
        have a bug on this (UPDATECENTER2-2077). I don't consider this a stopper for 2.3u2 since
        the upgrade works. We should mention it in the release notes.

            • This issue has been marked as a duplicate of 2077 ***
        Mike Fitch added a comment -

        Writeup added to the "Known Issues and Workarounds in This Release" section of
        the 2.3u2 Release Notes.


          People

          • Assignee:
            Joe Di Pol
            Reporter:
            lalithasaroja
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: