updatecenter2
  1. updatecenter2
  2. UPDATECENTER2-220

OS X: update tool can NOT be launched from notifier icon

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-MS06
    • Fix Version/s: 2.0-MS14
    • Component/s: doc
    • Labels:
      None
    • Environment:

      Operating System: Mac OS X
      Platform: Macintosh

    • Issuezilla Id:
      220

      Description

      1) created new user image and installed example package
      2) published new update
      3) launched notifier using command : "updatetool --notifier"
      4) icon appears in the system tray
      5) PROBLEM: clicking on it does NOT launch updatetool

        Activity

        Chris Kasso added a comment -

        I confirmed the issue. Clicking on the icon does not result in the GUI
        being launched. It doesn't look like WX is passing the button press
        event to the notifier (it does on other platforms).

        Launching the GUI via the notification balloon or via the notifier
        menu attached to the icon works fine.

        I've lowered the priority of this bug because the GUI can be launched
        via these other means and this problem is only seen on Mac.

        Chris Kasso added a comment -

        Some further investigation suggests this is not supported on the Mac WX impl.

        The following is from:

        http://www.wxpython.org/migrationguide.php

        Because of how it is implemented on the Mac using the Dock most of the
        TaskBarIcon events will not be emitted on that platform, but since 98% of the
        time you simply want to display an icon and have a popup menu it shouldn't be
        much of a problem. You can still use the other events on the other platforms,
        you'll just want to be sure that you can do everything you want via the menu too.

        Some further investigation is necessary but it is looking less likely this can
        be supported on the Mac.

        Chris Kasso added a comment -

        This action can not be supported on Mac OS X. The Mac OS X
        wxPython implementation does not support catching events on
        the taskbar icon.

        I've changed this issue to the doc category so that our
        documentation can address this functionality change on
        the OS X platform.

        ckamps added a comment -

        I'm marking as "fixed" given that the limitation has been addressed in recent
        updates to the online help content.


          People

          • Assignee:
            Mike Fitch
            Reporter:
            jlaska
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: