Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.3
    • Fix Version/s: None
    • Component/s: updatetool
    • Labels:
      None
    • Environment:

      Mac OSx 10.7.3, GlassFish 3.1.2

      Description

      1. download GF 3.1.2 (release), bootstrap updatetool (glassfish3/bin/updatetool), then start the updatetool
      2. once started, click on "Update Tool" menu on the topside bar of Mac OSx (at the right of the apple icon).
      3. The update tool crashes with the following message:

      GlassFish Update Tool does not support running in "mac-roman" encoding for "None" locale.
      Please set your environment to "None.UTF-8" and try again.
      Attempting to use English locale.
      /Users/rgrecourt/glassfish3/updatetool/UpdateTool.app/Contents/MacOS/../../../bin/updatetool:
      line 286: 91730 Bus error: 10           "$my_python/bin/$my_python_cmd" 
      "$my_home/../vendor-packages/updatetool/main.py" "$@" "--toolpath=$my_home/updatetool"
      

        Activity

        Joe Di Pol added a comment -

        I've reproduced this on 10.7.3. It has nothing to do with the locale setting. Once updatetool is up it appears to function correctly except for the "Update Tool" and "Window" menus. Touching these menus results in python (and hence updatetool) crashing.

        Joe Di Pol added a comment -

        Attaching a crash log.

        For reference UC is using wxPython version 2.8.10.1. The latest 2.8 version is now 2.8.12.1. We may want to consider trying that to see if it fixes the problem.

        Joe Di Pol added a comment - - edited

        I've been unable to reproduce this on 10.7.5 and 10.9 – so maybe something was fixed in Mac OS?


          People

          • Assignee:
            Joe Di Pol
            Reporter:
            Romain Grécourt
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: