utf-x
  1. utf-x
  2. UTF_X-28

report validation errors in xsl and test xml

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.0.6 alpha
    • Fix Version/s: 0.0.7
    • Component/s: framework
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      28

      Description

      If the xsl or xml is invalid, you just get a message saying "0 tests" and you
      have to view the log file to see any errors. It would be useful to see any
      validation errors in the test summary.

        Issue Links

          Activity

          jacekrad added a comment -

          well ... this isn't an easy one. the problem is that tests are being built by
          the JUnit framework and there are no hooks into that process. If a test build
          fails we can only log the error message (this may already happen). If a single
          test is broken inside a TDF then a MalformedTestException is thrown and
          displayed during a test run, but this does not deal with not well formed TDF's
          or broken XSLT stylesheets. We can do one of the following:

          1. log errors when either XSLT or XML TDF is broken
          2. Have a special BrokenTestCase which fails/errors when executed
          3. Drop JUnit and provide our own core framework. I have actually already
          implemented this when doing some experiments.
          4. Check out JUnit 4.0 to see if it provides any callbacks for the test
          assembly process.

          I have raised this issue with Erich Gamma at the 2004 JavaOne and he told me he
          was aware of the problem; perhaps he fixed this in junit 4,.0

          other thoughts anyone?

          jacekrad added a comment -

          Created an attachment (id=7)
          prooposed output format

          jacekrad added a comment -

          please have a look at the attached screen shot. tests 19 is the result of a not
          well formed TDF and test 20 is the result of a bad stylesheet. Do we need
          seperate way of showing bad TDFs and bad stylesheets? I guess the answer is yes.

          jacekrad added a comment -

          I'm implementing options 1 and 2


            People

            • Assignee:
              jacekrad
              Reporter:
              mac_sally
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: